l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
November 4: Social gathering
Next Installfest:
TBD
Latest News:
Oct. 24: LUGOD election season has begun!
Page last updated:
2010 Feb 28 16:37

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Problems installing and running UNIX based programs
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Problems installing and running UNIX based programs



On Sun, Feb 28, 2010 at 01:32:58PM -0800, Jason Snyder wrote:
> I am having problems with installing programs on LINUX ubuntu 9.10.  That
> includes having problems setting environments using setenv.  Is it possible
> to have some one go over the program webpages to help me install
> some of these programs?
> 
> One such program is called GrADS on the website for this is:
> 
> 
> http://www.iges.org/grads/downloads.html
> 
> Based on this website can you help give me guidance on how to install
> GrADS?  This would help be to able to install other similar programs.

The file on the GrADS website linked from "ubuntu-8.04 (32-bit)" is just
an archive of binaries. Just copy the files to ~/bin, /usr/bin, or
/usr/local/bin, and they'll be fine.

> 
> Another program I tried installing is NetCDF:
> 
> http://www.unidata.ucar.edu/software/netcdf/
> 
> when I tried running the install program make install I got the following
> message:
> 
> snyderjm@snyderjm-laptop:~/Desktop/netcdf-4.0.1$ make install
> Making install in f90
> make[1]: Entering directory `/home/snyderjm/Desktop/netcdf-4.0.1/f90'
> make  install-am
> make[2]: Entering directory `/home/snyderjm/Desktop/netcdf-4.0.1/f90'
> make[3]: Entering directory `/home/snyderjm/Desktop/netcdf-4.0.1/f90'
> make[3]: Nothing to be done for `install-exec-am'.
> test -z "/usr/local/share/man/man3" || /bin/mkdir -p
> "/usr/local/share/man/man3"
> /bin/mkdir: cannot create directory `/usr/local/share/man/man3': Permission
> denied
> make[3]: *** [install-man3] Error 1
> make[3]: Leaving directory `/home/snyderjm/Desktop/netcdf-4.0.1/f90'
> make[2]: *** [install-am] Error 2
> make[2]: Leaving directory `/home/snyderjm/Desktop/netcdf-4.0.1/f90'
> make[1]: *** [install] Error 2
> make[1]: Leaving directory `/home/snyderjm/Desktop/netcdf-4.0.1/f90'
> make: *** [install-recursive] Error 1

Try running this is as root or with superuser powers (sudo make install).

> 
> 
> Thanks,
> 
> Jason

> _______________________________________________
> vox-tech mailing list
> vox-tech@lists.lugod.org
> http://lists.lugod.org/mailman/listinfo/vox-tech

-Eric
Go Team USA!
_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
O'Reilly and Associates
For numerous book donations.