l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
September 2: Social gathering
Next Installfest:
TBD
Latest News:
Aug. 18: Discounts to "Velocity" in NY; come to tonight's "Photography" talk
Page last updated:
2010 Feb 28 16:19

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Problems installing and running UNIX based programs
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Problems installing and running UNIX based programs



Jason Snyder wrote:
> I am having problems with installing programs on LINUX ubuntu 9.10.  That
> includes having problems setting environments using setenv.  Is it possible
> to have some one go over the program webpages to help me install
> some of these programs?
> 
> One such program is called GrADS on the website for this is:
> 
> 
> http://www.iges.org/grads/downloads.html
> 
> Based on this website can you help give me guidance on how to install
> GrADS?  This would help be to able to install other similar programs.
> 
> Another program I tried installing is NetCDF:
> 
> http://www.unidata.ucar.edu/software/netcdf/
> 
> when I tried running the install program make install I got the following
> message:
> 
> snyderjm@snyderjm-laptop:~/Desktop/netcdf-4.0.1$ make install
> Making install in f90
> make[1]: Entering directory `/home/snyderjm/Desktop/netcdf-4.0.1/f90'
> make  install-am
> make[2]: Entering directory `/home/snyderjm/Desktop/netcdf-4.0.1/f90'
> make[3]: Entering directory `/home/snyderjm/Desktop/netcdf-4.0.1/f90'
> make[3]: Nothing to be done for `install-exec-am'.
> test -z "/usr/local/share/man/man3" || /bin/mkdir -p
> "/usr/local/share/man/man3"
> /bin/mkdir: cannot create directory `/usr/local/share/man/man3': Permission
> denied
> make[3]: *** [install-man3] Error 1
> make[3]: Leaving directory `/home/snyderjm/Desktop/netcdf-4.0.1/f90'
> make[2]: *** [install-am] Error 2
> make[2]: Leaving directory `/home/snyderjm/Desktop/netcdf-4.0.1/f90'
> make[1]: *** [install] Error 2
> make[1]: Leaving directory `/home/snyderjm/Desktop/netcdf-4.0.1/f90'
> make: *** [install-recursive] Error 1
> 
> 
> Thanks,
> 
> Jason
> 
Netcdf

sudo make install
(This command requires permission to write to /usr/local so you need to
use sudo)


If version 3.6 works for you though just use it from the repositories.
sudo apt-get install netcdf-bin
The advantage is that you don't have to worry about it, and the python
bindings are also available.

As for GrADS
./configure
make
sudo make install

should work...

Though for all cases where you use make install I highly suggest
checkinstall (you need to install it first)
sudo checkinstall
This creates a deb package specific to your machine and the package gets
installed via the package manager which keeps the system cleaner for
upgrades later.

Alex
_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.