l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2010 Feb 22 21:58

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Fwd: When I boot my server all it says is "GRUB"
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Fwd: When I boot my server all it says is "GRUB"

Just getting back to normal now.

As I previously described in my original post, my server halted in the
first boot phase with the message GRUB. Very annoying.

After reading the RHEL manual and booting via the linux rescue disk, I
unsuccessfully tried both /sbin/grub-install and grub-install --recheck.
Eventually I sorted out (with some help from Henry) that it was stuck
at the first phase of booting. So I ran grub manually and recreated the
boot blocks on all members of the raid array. After doing that, the
server came right up.

Thanks to all who offered help.

-- Dave Spencer, PageWeavers

--- Original Message ---

On Sun, Feb 21, 2010 at 07:19:41PM -0800, Nick Schmalenberger wrote:
> On Sun, Feb 21, 2010 at 01:01:43PM -0800, Bill Kendrick wrote:
> > 
> > David tried to post this to 'vox' from an unsubscribed address,
> > so it got discarded by mailman.
> > 
> > I'm passing it along to 'vox-tech', since it's more appropriate
> > for that list, than for 'vox'.  Also Cc'ing LERT coordinators,
> > in case anyone is around and can perhaps do a housecall.
> > 
> > -bill!
> > 
> > ----- Forwarded message from vox-bounces@lists.lugod.org -----
> > 
> > The attached message has been automatically discarded.
> > Date: Sat, 20 Feb 2010 20:04:08 -0800
> > From: David Spencer <spencer@pageweavers.com>
> > Subject: When I boot my server all it says is "GRUB"
> > To: vox@lists.lugod.org
> > 
> > Hey guys. I was fiddling with my servers this afternoon. I rebooted one of them and all it says is GRUB. WTF?
> > 
> > The system in question is a Dell SC1425 with drives in a RAID 1. The OS is CENTOS 4.8 . What what it's worth, I recently ran a yum update on Thursday (two days ago).
> > 
> > Any ideas what I can do? I have it booted at the moment using the linux rescue mode but what should I be looking at?
> > 
> > Thanks!
> >
> In rescue, try to mount the root filesystem, and /boot if it is a
> separate filesystem. Then chroot to the mountpoint of the root
> filesystem ("chroot /mnt" or something), and do "grub-install
> (hd0)" (the grub way of saying the disk) or "grub-install
> /dev/sda" or /dev/sda1 or whichever disk/partition is the root
> filesystem. I'm not sure if its more appropriate to install grub
> on the disk or partition but I don't think it hurts to try both.
> While the root filesystem is mounted you can also make any
> corrections to the menu.lst if needed.
> Nick Schmalenberger
Also, if you are booting a raid mirror be sure to install grub on
both drives and confirm they are both bootable without the other
drive. Its easy to forget about this until a disk needs to be
replaced and the server is already shutdown.
vox-tech mailing list
vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.