l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2008 Sep 26 17:08

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] usb stick stopped mounting
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] usb stick stopped mounting

Tony Cratz wrote:
> Alex Mandel wrote:
>> It's odd, but one of my usb sticks stopped mounting automatically and in 
>> fact doesn't want to work at all.
>> dmesg gives:
>> [  724.103868] sd 6:0:0:0: [sdb] Device not ready: Sense Key : Not Ready 
>> [current]
>> [  724.103871] sd 6:0:0:0: [sdb] Device not ready: Add. Sense: Medium 
>> not present
>> [  724.103874] end_request: I/O error, dev sdb, sector 32
>> Other usb drives are working fine, and this stick still works fine on 
>> windows too. fdisk, mount, gparted all fail to see /dev/sdb
>> There are 2 things I can think of that might have caused the error. The 
>> first is that I was running applications off the drive through wine. 
>> Specifically portableapps.com , maybe I didn't unmount it cleanly or 
>> something although I'm sure I shut down wine and did a normal unmount 
>> before removing it.
>> Option 2 is somehow installing Virtualbox has screwed with it or the usb 
>>   drive mounting rules.
>> Any ideas where to even start, I would backup and reformat if I thought 
>> I could but without it mounting that doesn't exactly make that possible.
> 	In the past when I tried to install Virtualbox and get USB
> 	working I had problems. But you say the other USB drives
> 	are working fine (with Virtualbox). Therefore the chance that
> 	Virtualbox is the problem is small.
> 	Is this a dual file system drive or is it all a NTFS partition?
> 	If it all NTFS you might try 'ntfsfix' to clean it (think fsck).
> 	That may solve your problem.
> 	You also said gparted failed to see it. Is it that it does not
> 	see the partition at all?
> 	How about other systems? Do they see it?
> 							Tony

It's actually ext3/ ext3/ fat32/, the first partition being bootable, 
well was bootable. Windows sees the fat32, and I'm backing it up now.
Disabling ehci_usb got the system to recognize it but put it into an 
endless loop waiting for it to be ready for mount.

I never tried or ever got it working with Virtualbox, I just mentioned 
that because it was the most recently installed application that might 
have influenced the problem.

fdisk, gparted etc all fail to see the device it never gets to the point 
where it's even accesible under /dev/sdx because the subsystem claims 
it's waiting for the device to stop being busy.

vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
O'Reilly and Associates
For numerous book donations.