l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
October 20: Web Application Hacking: How to Make and Break Security on the Web
Next Installfest:
TBD
Latest News:
Oct. 10: LUGOD Installfests coming again soon
Page last updated:
2007 Apr 05 07:35

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
[vox-tech] Kubuntu Edgy Eft on an IBM (Lenovo) ThinkPad X41 Tablet(mostly-success story)
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[vox-tech] Kubuntu Edgy Eft on an IBM (Lenovo) ThinkPad X41 Tablet(mostly-success story)



My wife Melissa just bought a used Thinkpad X41 tablet -- it's a laptop
which has a Wacom tablet built into the LCD (so you can draw on it directly,
using a stylus).  The LCD can swivel around and hide the keyboard.

The device does not have a built-in CDROM or DVD drive, and didn't come with
an external one, so I followed some instructions found here to boot
the Ubuntu installer over the network (PXE boot).

  http://www.thinkwiki.org/wiki/Installing_Ubuntu_6.10_on_a_ThinkPad_X41_Tablet

First I tried Feisty Fawn (which is the forthcoming Ubuntu 7.04
release, still beta), but when that failed, I went to Edgy Eft (6.10),
which worked fine.  (I did this over ethernet, not wireless.)

I just wanted to report the success and failure we've had with the
device so far.

* PXE boot - worked great.  Ubuntu installer didn't need much from me,
  and offered to install Kubuntu desktop (so we got KDE, and didn't get
  GNOME, which would've been extraneous)

* Disk partitioning - the laptop came with a fresh WinXP installed on it;
  I did a disk defrag first thing (it was, like, 28% fragmented!).
  Ubuntu installer shrunk the XP partition for me, making space for
  Linux / (root folder) and swap partitions, and then set them up.
  (When I rebooted XP, it told me it needed to check its partition,
  and did so without any problems. *WHEW*!)

* GRUB - worked out of the box.  Ubuntu (and Ubuntu rescue), and WinXP
  (as well as the rescue parition that has some mini Windows on it) are
  listed at boot-up.

* Wireless - worked out of the box.  Wireless assistant in KDE got me up
  on the WEP-password-protected network in our house without any problem!

* Sound - worked out of the box.  KDE's startup jingle proved it.

* Tablet screen - worked out of the box.  Pressure sensitivity works
  (tested with GIMP)!

* Screen rotation in tablet orientation - DID NOT WORK out of the box.
  See below.

* Suspend / Hibernate - worked out of the box.  (Except the Fn+nnn hotkeys.)
  Melissa tweaked KDE's settings to have it hibernate instead of suspend
  when she closes the lid.  Worked great.

* SD Card Reader - Worked.  (Didn't seem to at first, then it did.)
  When KDE was still showing icons on the desktop (Melissa prefers it doesn't),
  a "mounted SD card" icon appeared on the desktop.  A window pops up in KDE
  asking if she'd like to open the SD card in a folder, or load the images
  into Digikam.

* Digital Camera via USB - Worked, after udev adjustment.  (Had to add our
  exact camera's manuf/product to the udev file.  See my recent post to
  vox-tech about Kubuntu and my Canon.)  A mounted camera icon appeared, and
  a window popped up, asking about opening the camera as a folder, or in
  Digikam.  Oh, I did also need to specifically add the camera in Digikam
  (Camera->Add Camera, or some such... then picked it from a list)

* iPod via USB - Worked out of the box.  Amarok noticed when it was plugged
  in, and offered to manage it.  Then the songs currently loaded onto the
  iPod appeared in the "Devices" tab in Amarok.  Sweet. :)


Untested so far:

* Fingerprint reader  (seem useless)

* Bluetooth  (we have nothing for it to talk to)

* PCMCIA  (haven't tried anything; no real use, since it has built-in
  ethernet, built-in wireless, and a built-in SD card reader!)

* Modem  (no real use)

* Accellerated 3D (not sure if it is even capable of accel?)


The two things we've tried to do that _haven't_ worked right yet are:

* Screen rotation -- having it run xrandr and xsetwacom to rotate the
  display, and the stylus orientation (so that it isn't sideways :^) )
  when the LCD is swiveled around to tablet orientation.
  I followed the instructions at the URL above, but noticed two things:

    1. Based on someone else's post on the ThinkWiki.org site,
       it works if ACPI was restarted _after_ X11 is running.
       This explains why this all worked right _the first time_, but not
       after a reboot.  I've made it so that when KDM starts up,
       "/etc/init.d/acpid restart" is executed (added to /etc/kde3/kdm/Xsetup)
    2. However, sometimes xrandr itself fails... silently... what gives?!
       (tried asking around "#linux" on freenode, but the people there were
       far more interested in having a Fedora vs Debian vs Kubuntu religious
       war... *sigh*)

* Pressure sensitivity into WINE -- Windows came pre-loaded with a trial
  version of Alias Sketchbook, which is a bitmap drawing program whose UI is
  design specifically for drawing pad (wacom tablet, tablet pc, etc.)
  I was able to get it running under WINE quite easliy, but the stylus
  pressure sensitivity isn't getting passed through from X to the Windows app.
  Apparently, this IS possible.  I see people saying that it works for them
  in Photoshop.  I don't know what I'm missing. :)


Finally, the thing has some buttons next to the screen (mostly useful when
its in tablet orientation).  Some of them work out of the box:

  * Escape
  * Enter
  * Page up
  * Page down
  * Power
  * Reset (presumably?  I think I heard it just acts like Ctrl+Alt+Del,
    which in KDE would bring up a "Shutdown/Reboot?" prompt...
    This button requires you poke it with the stylus, or a pen or paperclip.)
  * Volume Up/Down/Mute (KDE shows an OSD for these, even!)
  * LCD Brightness Up/Down (Fn+Home/End)
  * LCD/VGA toggle (Fn+F7)

Buttons that don't work:

  * Toolbox
  * Rotate
  * Hibermate (Fn+12)
  * Suspend (Fn+?) (I THINK it has this key :^) )

I need to look into this, assuming they're even important to Melissa.


Note that Emperor Linux actually sells this laptop (or sold -- it's since
been replaced by the X60 tablet by Lenovo), pre-loaded with Linux, and
they claim _everything_ works.

  http://www.emperorlinux.com/mfgr/lenovo/raven/?tab=details&id=302

That X60 costs nearly 3x what we spent for a used, WinXP-toting one,
though. :^(

In the meantime, hopefully someone out there'll find this useful or
encouraging. :)

With the built-in wacom, I'm kinda wanting one of these, too, damnit! :^P

-- 
-bill!
bill@newbreedsoftware.com
http://www.newbreedsoftware.com/
_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.