l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
September 2: Social gathering
Next Installfest:
TBD
Latest News:
Aug. 18: Discounts to "Velocity" in NY; come to tonight's "Photography" talk
Page last updated:
2006 Nov 05 07:05

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
[vox-tech] NICs not detected / accessible during Debian Etch install
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[vox-tech] NICs not detected / accessible during Debian Etch install



Hmmkay ... I hope someone can help me with this issue - I'm running out of ideas.

I've got a machine I'm trying to install a Debian-variant (ANY!! variant) onto, and either the installer refuses to see the NICs, or the installer finds the NICs, but DHCP doesn't work.

The machine is a frankenbox, (w) a VIA KM266 chipset mobo (MSI MS-6390) driving a Duron 950, RealTek8101L ethernet on the board (identifies sometimes as rtl8139), and a Realtek 8139 in a PCI slot.
When I run an installer from the most recent Etch builds (a full-install disk from about 2 weeks ago, and net install daily release from last week) the installer gets to the "detect & add network hardware" section, and gives me a screen saying "I couldn't detect your NIC - please select a driver from the list." When I select either of the rtl8139 drivers, the installer tries to use that driver, fails to do so, and returns me to the choose a driver screen. I've also tried an etch installer from a few months ago, and a Sarge installer from last week; the installer detects the cards, but is unable to pull an IP from the DHCP server on the DSL router.

Knoppix disks and the most recent kubuntu installer simply refuse to detect the card. Within knoppix, trying to bring it up manually (ifconfig eth0 inet dhcp ... or insmod (driver name) didn't work ... though I'd have to repeat the steps to note down the returned error messages).

While chasing this down I have
a) tried many of the above tests with the on-board nic turned on in BIOS, vs. turned off ...
b) tried the above tests with the PCI card removed, to JUST access the onboard NIC
c) tried switching out the PCI nic for a US Robotics card, and running many of the above tests (PCI card in and out, onboard card on and off).
d) Tried putting a full install from the CD on the machine, then activating the NIC manually.
e) Booted into the demo Win Server 2003 install that's sitting on /dev/hda1 to test the cards. Windows boots up properly, loads up, and grabs an IP from the router (confirmable from the router control panel).
f) Tried the realtek PCI card in another machine, to confirm that it shows up in linux.
g) Tried a net-install of OpenSUSE. That didn't work either. Once I followed the menu options in the installer to activate the IDE controller (for the CD) and the networking hardware, it refused to go further -- it couldn't see the install media, and I gather couldn't go out onto the web for it either. *shrug*

The only thing I haven't explored fully is an 'IRQ conflict' ... but I'm not sure how to pursue that ... and why didn't the same thing show up within Windows? (According to some net searches, the 2.4/2.6 kernels should be just as much of a plug-and-play OS as Windows).

Any ideas?

Thanks,

Richard Burkhart
_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
EDGE Tech Corp.
For donating some give-aways for our meetings.