l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
September 2: Social gathering
Next Installfest:
TBD
Latest News:
Aug. 18: Discounts to "Velocity" in NY; come to tonight's "Photography" talk
Page last updated:
2006 May 24 07:39

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Building kernel for kubuntu
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Building kernel for kubuntu



On Tue May 23 2006 11:45, Ken Bloom wrote:
> On Tue, May 23, 2006 at 10:30:09AM -0700, Richard Harke wrote:
> > I have a laptop with athlon 64 and I have installed kubuntu amd64
> > I built custom kernel at version 2.6.12 source from ubuntu and with
> > ubuntu patches.
> > I can't get it to boot. It claims /dev/hda1 doesn't exist. But it
> > certainly exists for the install kernel. I suspect a problem with the
> > initrd because I had that problem on another machine (not amd64, Debian)
> > where
> > docs said not to use mkinitrd but something newer. In the end I had
> > to use mkinitrd, the image made with the newer tool couldn't be
> > loaded. The current inird is built with mkinitramfs (Don't remember
> > if this was name on the other system) I installed initrd-tools which
> > has mkinitrd and tried that. But I don't get a file! Command is:
> >         mkinitrd -o initrd.img 2.6.12_G1 where 2.6.12_G1 is the version
> > of the kernel I built.
> > Does anyone know what is going on?
My mistake. I didn't supply the version to mkinitramfs so it
loaded modules for the running kernel, not the kernel I had just built.
>
> I seem to recall issues with mkinitrd and newer kernels and debian.
> Try yaird (Yet Another mkInitRD).
On my other machine, a couple of months back, that is what I tried to use
because there was documentation stating mkinitrd was obsolete. But
the image built by yaird couldn't be loaded and when I went back to mkinitrd
it worked fine.
>
> Alternatively, determine what modules the kernel is loading, and then
> compile those into your 2.6.12_G1. (And while you're at it, consider
> updating to 2.6.16)
I'm not sure that will work. I tried it once and it didn't work but I don't 
know if I missed some essential module or if its because it needs the
scripts that are also in initrd. 2.6.12 seemed to be the only kernel
source available from ubuntu, at least for breezy badger.
> --Ken
_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.