l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
October 20: Web Application Hacking: How to Make and Break Security on the Web
Next Installfest:
TBD
Latest News:
Oct. 10: LUGOD Installfests coming again soon
Page last updated:
2005 Mar 21 13:41

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
[vox-tech] Unable to mount LVM drive after updating from Deb Sargeto Sid
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[vox-tech] Unable to mount LVM drive after updating from Deb Sargeto Sid



Well, in a nutshell, the subject says it all. I recently went from
Debian Sarge to Sid. In that process, quite a few packages were
upgraded. I know the LVM package was one of them. I also went from a
2.6.7 (yes, I know that wasn't the most recent in Sarge) to 2.6.10.
After rebooting into the new kernel, I realized I couldn't access the
files on my LVM drive. A little poking around told me the drive wasn't
mounting. I tried booting back into the 2.6.7 kernel, but I had the same
problem. So, at this point I don't think it's a kernel problem. I'm also
guessing it has nothing to actually do with upgrading LVM (although, I
could of course be wrong about that).

My guess as to what actually happened is some sort of corruption that
reared it's head at just the wrong time. The machine had an uptime of
around 2 months, and I'm guessing the problem could have occurred any
time in that 2 months, and it just didn't show up until a reboot.

Anyways, here's how the problem presents now... I've got 3 80GB drives
in my system. /dev/hda has a number of partitions for /usr /home /boot
etc, with the remainder in hda10 going to the LVM. I've also got hdf and
hdh completely to the LVM. The problem LVM is showing seems to have to
do solely with hdh.

# cat /var/log/dmesg
[cut]
hdf: cache flushes not supported
 /dev/ide/host2/bus0/target1/lun0:
Probing IDE interface ide3...
hdh: MAXTOR 6L080J4, ATA DISK drive
ide3 at 0x9800-0x9807,0x9c02 on irq 169
hdh: max request size: 128KiB
hdh: 156355584 sectors (80054 MB) w/1819KiB Cache, CHS=65535/16/63, UDMA(133)
hdh: cache flushes supported
 /dev/ide/host2/bus1/target1/lun0: p1
VP_IDE: IDE controller at PCI slot 0000:00:11.1
ACPI: PCI Interrupt Link [ALKA] BIOS reported IRQ 0, using IRQ 20
ACPI: PCI Interrupt Link [ALKA] enabled at IRQ 20
ACPI: PCI interrupt 0000:00:11.1[A] -> GSI 20 (level, low) -> IRQ 177
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
VP_IDE: VIA vt8235 (rev 00) IDE UDMA133 controller on pci0000:00:11.1
    ide0: BM-DMA at 0xb800-0xb807, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xb808-0xb80f, BIOS settings: hdc:DMA, hdd:DMA
Probing IDE interface ide0...
hda: ST380013A, ATA DISK drive
[/cut]

That all looks like it's supposed to. Or at least I think it does. I'm
mainly showing it to show that hdh seems to be found just fine during
bootup, It's just LVM that seems to have trouble with it.

# /sbin/pvdisplay
  Couldn't find device with uuid 'dxlaHI-Bv7g-ID51-1Coy-gDnc-sKmJ-a5oWQ2'.
  Couldn't find device with uuid 'dxlaHI-Bv7g-ID51-1Coy-gDnc-sKmJ-a5oWQ2'.
  --- Physical volume ---
  PV Name               unknown device
  VG Name               media
  PV Size               74.55 GB / not usable 0   
  Allocatable           yes (but full)
  PE Size (KByte)       4096
  Total PE              19086
  Free PE               0
  Allocated PE          19086
  PV UUID               dxlaHI-Bv7g-ID51-1Coy-gDnc-sKmJ-a5oWQ2
   
  --- Physical volume ---
  PV Name               /dev/hdf
  VG Name               media
  PV Size               74.53 GB / not usable 0   
  Allocatable           yes (but full)
  PE Size (KByte)       4096
  Total PE              19079
  Free PE               0
  Allocated PE          19079
  PV UUID               tcWV0m-lvQU-qrN7-HNF7-SKVB-T6om-3EneY7
   
  --- Physical volume ---
  PV Name               /dev/hda10
  VG Name               media
  PV Size               66.93 GB / not usable 0   
  Allocatable           yes 
  PE Size (KByte)       4096
  Total PE              17135
  Free PE               1
  Allocated PE          17134
  PV UUID               WYNOmu-13s1-tE71-GsnF-abrr-c63H-xtL1eU

I get similar error messages through most of the lvm commands. It always
can't find the device with that uuid. The thing I don't understand is
that the device with that uuid shows up in the pvdisplay command, but it
doesn't seem to be able to figure out that it should be pointing at
/dev/hdh. I've read through the manpages of all the lvm commands, and
can't seem to find anything to point me in the right direction. I've
also googled the best I could and tried to find a way to fix it there.
Unfortunately, nothing helped, and most of what i did was at least a
week or so ago, so I couldn't tell you at this point exactly what I've
tried. I'm hoping someone here has a better idea than I do, because I am
mostly clueless when it comes to LVM.

Thanks,
Rob
_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
O'Reilly and Associates
For numerous book donations.