l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2005 Jan 01 15:13

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Getting new Linux box to boot
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Getting new Linux box to boot

This is merely a problem of not having a boot loader of any sort installed in 
the MBR.

You need a boot loader config file.  In your case grub.  Grub looks for its 
config file in /boot/grub/grub.conf, /etc/grub.conf or /boot/grub/menu.lst.

1.  Do you have a valid grub.conf file for your system?  After you have a 
grub.conf file then you can move to step 2, see my example below.

2.  You must boot from a rescue disk of some sort, Tom's or Knoppix.  If the 
machine has a CD, I would recommend Knoppix.

3.  Once you have booted into a rescue environment you need to mount your 
filesystems as they will be configured in your final running system.  Since 
you only have 1 partition this is not an issue.  Open up a root shell and 
mount your root partition (/) of your system onto a mount point.

mkdir system
mount /dev/hda1 system
cd system
chroot .
vi /boot/grub/grub.conf

title My Linux System
        root (hd0,0)
        kernel /boot/vmlinuz-2.4WHATEVERYOURKERNEL ro root=/dev/hda1
        initrd /boot/initrd-2.4.WHATEVERYOUR_INITRD_IMAGE
## NOTE, you may or may not need an initrd image depending on your kernel

now, let's install the boot loader into the MBR

grub-install /dev/hda

You should see some output from grub as it writes to the MBR and installs 
itself.  Now we need to exit from the chroot environment and reboot.


shutdown -r now

See if the system comes up.  I may have missed a thing or two... but you 
should have a boot loader installed......

On Saturday 01 January 2005 12:46, Richard S. Crawford wrote:
> It worked, so the interpreter is good.
> > > Also, when I tried chroot:
> > >
> > > # chroot /mnt/lmx /bin/sh
> > >
> > > I got:
> > >
> > > illegal instruction
Mark Street, RHCE
Key fingerprint = 3949 39E4 6317 7C3C 023E  2B1F 6FB3 06E7 D109 56C0
GPG key http://www.oswizards.com/pubkey.asc
vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Sunset Systems
Who graciously hosts our website & mailing lists!