l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2004 Dec 04 14:57

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] NFS Mounting Error
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] NFS Mounting Error

On Sat, 4 Dec 2004, Peter Jay Salzman wrote:

On Sat 04 Dec 04, 10:44 AM, Chris Jenks <jenks@resonance.org> said:

  I am trying to mount a NFS volume where both machines are on the same
home network, but I get the following errors. From the client:

[root@pinky mnt]# mount -t nfs /mnt/tmp
mount: failed, reason given by server: Permission denied

On the server:

cruncher:/# tail /var/log/syslog
Dec  4 10:30:31 cruncher rpc.mountd: authenticated mount request from for /tmp (/tmp)
Dec  4 10:30:31 cruncher rpc.mountd: getfh failed: No such device
Chris, if massive log file reading and Googling didn't turn up anything
useful, what I would try as a second stab would be to run nfsd by hand with

# strace -o /root/nfsd.log rpc.nfsd

and look for something that looks like an error near the bottom of the file.
It may not tell you anything useful, but often time strace will tell you the
real, "low level" reason why something failed, which can sometimes be very

Dear Pete,

Thanks for the new tool. I tried it out on rpc.nfsd and it gave:

close(5) = -1 EBADF (Bad file descriptor)
close(4) = -1 EBADF (Bad file descriptor)
close(3) = 0
open("/proc/fs/nfsd/threads", O_WRONLY) = -1 ENOENT (No such file or directory)
open("/proc/fs/nfs/threads", O_WRONLY) = -1 ENOENT (No such file or directory)
nfsservctl(0, 0xbffff4c0, 0) = -1 ENODEV (No such device)
time([1102190507]) = 1102190507
open("/etc/localtime", O_RDONLY) = 3

near the end. Also, I ran exportfs -ra in the same way, and got:

open("/var/lib/nfs/xtab", O_RDONLY) = 5
fstat64(5, {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40018000
read(5, "", 4096) = 0
read(5, "", 4096) = 0
close(5) = 0
munmap(0x40018000, 4096) = 0
close(3) = 0
nfsservctl(0x1, 0xbfffe7f0, 0) = -1 ENODEV (No such device)
write(2, " No such device"..., 33) = 33
open("/var/lib/nfs/etab", O_RDWR|O_CREAT, 010000510074) = 3
rt_sigaction(SIGALRM, {0x804dec0, [], 0}, {SIG_DFL}, 8) = 0

A google search revealed that nfsservctl is a "syscall interface to kernel nfs daemon." Command number 0 means "This is a server process," while command number 0x1 means "Add an NFS client." I suspect that my kernel configuration is at fault. I'll look at it.


vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Sunset Systems
Who graciously hosts our website & mailing lists!