l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
October 20: Web Application Hacking: How to Make and Break Security on the Web
Next Installfest:
TBD
Latest News:
Oct. 10: LUGOD Installfests coming again soon
Page last updated:
2004 Oct 09 22:01

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
[vox-tech] ssh connection closed
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[vox-tech] ssh connection closed



This is really a follow up to a thread three years ago. I have the same
problem as described here:

http://lugod.org/mailinglists/archives/vox-tech/2001-10/msg00045.html

I could not find any follow ups that indicated how Peter solved the
problem.

My problem is intermittent. My server (colo on another continent, so no
 physical access) was installed on Friday. An initial SSH problem was
solved when the colo provider edited /etc/hosts.deny.

SSH worked fine for a while on Friday evening. The only config changes
I made was adding ALL: ALL to /etc/hosts.allow, disabling SSH
authentication other than password and changing user passwords. After
about an hour I started getting the following error message:
ssh_exchange_identification: Connection closed by remote host.

On Saturday morning everything was working again - so I assume the
problem was not Friday's config changes. I transfered some files with
sftp, installed Active TCL (the installer just copies some files to /
usr/local so should not change anything else), and installed the
tcltls RPM.

A few hours later I started getting the same error message again. Its been
the same since.

ssh -v -v -v me@[my server ip]

gives

OpenSSH_3.6.1p2, SSH protocols 1.5/2.0, OpenSSL 0x0090703f
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Rhosts Authentication disabled, originating port will not be
trusted.
debug2: ssh_connect: needpriv 0
debug1: Connecting to [my server ip] port 22.
debug1: Connection established.
debug1: identity file /home/[home directory]/.ssh/identity type -1
debug1: identity file /home/[home directory]/.ssh/id_rsa type -1
debug1: identity file /home/[home directory]/.ssh/id_dsa type -1
ssh_exchange_identification: Connection closed by remote host
debug1: Calling cleanup 0x80628b0(0x0)


telnet [my server ip] 22

gives

Trying [my server ip]...
Connected to [my server ip] ([my server ip]).
Escape character is '^]'.
Connection closed by foreign host.

hosts.allow contains ALL: ALL, hosts.deny has no uncommented lines.

I do not think it is a firewall config (I am using shorewall) as
telnetting to the default telnet port (which is blocked) gives a very
different response. Also, surely, accidentally blocking something
should create an intermittent problem? Although I have not got
through for some time now (Sunday morning)

The only (very weak) idea I have come up with is that it is something
to do with my use of Konqueror sftp and fish protocols: an "initiating
protocol" message comes up a LOT of times when copying a directory.

Both machines are running Mandrake 10. I have recently been using SSH
regularly between Mandrake 10 machines with default SSH configs, including
 one with an identical shorewall config,  and I have had no problems
except with this one - needless to say the most important (the others
 were desktops) and the least accessible.

Thanks for any help as I have spent a day and a half googling for
answers and have found nothing but "check your hosts.deny".

Graeme
_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
EDGE Tech Corp.
For donating some give-aways for our meetings.