l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
December 2: Social gathering
Next Installfest:
TBD
Latest News:
Nov. 18: Club officer elections
Page last updated:
2004 Aug 24 15:26

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] debian woody to sarge upgrade = dead xserver
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] debian woody to sarge upgrade = dead xserver



On Tue, Aug 24, 2004 at 03:03:37PM -0700, Ashleigh Smythe wrote:
> Hi ya'll.  Well I was finding packages a bit outdated with woody so I 
> thought I'd upgrade my home desktop (Dell Dimension 2400 Pentium 4, 
> 2.66 GHz) to sarge.  I followed Rick Moen's directions for upgrading 
> potato to woody: 

[snip]

> This all seemed to go fine, but upon reboot, startx aborts completely 
> and falls back to the command prompt.  There is a long log in 
> /var/log/XFree86.0.log with the errors near the end being: 
> 
> Fatal server error: 
> Caught signal 11.  Server aborting 
> 
> XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0:0" 
> after 0 requests (0 known processed) with 0 events remaining. 
> 
> I'm sorry I can't post the whole thing, I don't have a zip drive on my 
> lap top that I'm emailing on right now so the error message is stuck on 
> the desktop (no X, no email).  I probably can later tonight if it seems 
> necessary.  I've been doing dpkg-reconfigure xserver-xfree86 (the 
> XFree86 package is 4.3.0.dfsg.1-4) and looking at my XF86Config-4 file 
> and the settings seem to be as they was before in woody when X was 
> working - I'm using the nv driver which worked with my nvidia geforce2 
> video card.   I've also tried not installing the modules that are 
> listed in dpkg-reconfigure xserver-xfree86 - like dri and glx but that 
> didn't seem to change anything.   One strange thing is that I'm certain 
> there was an option about not using framebuffers that I needed to use 
> to get X to work with woody, but now I don't see it in the xfree86 
> reconfigure tool or in my XF86Config-4 file - I could be confused about 
> where that was though. 
> 
> Any suggestions?  I've been googling for several hours but I think that 
> error message is pretty generic as people seem to be seeing it for all 
> kinds of things - mice, keyboards, wrong video cards.   

There's most likely a much better pointer to the error in the X log
file. try looking at the /var/log/XFree86.0.log file. Near the top
(about 10-15 lines down) you should see:

Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

And continuing on down from there, most lines will start with one of
those markers. If you do a search through the file for "(EE)" and tell
us what you find, we can probably give you a much better idea what the
actual problem is. (or it may even become obvious to you at that point)
_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Sunset Systems
Who graciously hosts our website & mailing lists!