l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2004 Jul 24 22:34

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
[vox-tech] X
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[vox-tech] X

My video card is a NeoMagic MagicMedia 256AV. My system is a laptop. My
X is version . About framebuffers, before I started researching
this problem, I had framebuffer support disabled in my kernel because
the help on it in the kernel config said it wasn't really necessary. The
X crashing and darkness problem _did_ happen before I had framebuffer
support enabled. However,this post:
(I pasted that the UNIX way!) indicated that framebuffer support might
solve my problem. So I recompiled my kernel with framebuffer support,
but it wouldn't work with the vesafb. Syslog says: "vesafb: probe of
vesafb0 failed with error -6"( What is error 6?) As the kernel doc for
vesafb says, "VESA BIOS Extensions Version 2.0 are required, because we 
need a linear frame buffer." So I tried the neomagic specific fb device
instead, and it seems to work. There were promising messages about neofb
at boot. Indeed, the console framebuffer did work. Tux appeared! 
However, X still did the dark thing when I switch back to it from the
console. Also, with the console framebuffer, when I switch to the
virtual console from X, the virtual console has a whole bunch of weird 
stuff all over it. If the console would have a new character appear,
if I do a clear, then that overwrites the weird stuff, but meanwhile
lost the last screenful of whatever it was I had been doing on the
before. If I do a Ctrl-Alt-Backspace from X, so X is killed instead of
just switched out of, then the virtual console that it goes back to that
I started X from is fine. The doc about vesafb says
"The X-Server must restore the video mode correctly, else you end up
a broken console (and vesafb cannot do anything about this)."
However, that problem was with neofb, vesafb won't even start.
 As I said above, that doc says that for vesafb to
work you need a VESA 2.0 compliant video BIOS. So I thought that was my
problem until I read in XFree86.0.log that my VESA BIOS is 2.0 .

(II) VESA(0): VESA BIOS detected
(II) VESA(0): VESA VBE Version 2.0
(II) VESA(0): VESA VBE Total Mem: 2496 kB
(II) VESA(0): VESA VBE OEM: MagicGraph 256 AV 48K
(II) VESA(0): VESA VBE OEM Software Rev: 1.17
(II) VESA(0): VESA VBE OEM Vendor: NeoMagic
(II) VESA(0): VESA VBE OEM Product: MagicMedia 256 AV
(II) VESA(0): VESA VBE OEM Product Rev: 01.0

No matter all of the stuff I tried, X still has the darkness and
crashing problem. The X crashing and darkness problem _did_ happen 
before I had framebuffer support enabled.

About the Mozilla problem, the whole reason I had posted about trying to
compile GTK last week was because supposedly Firefox requires it. I
wanted firefox because that was what I had been using in Windows before
I got my NIC to work in Linux, and I had a nice collection of
bookmarks and stuff. Apparently (this list says so), Firefox is faster
too. So, I got this
binary Firefox installer for Linux from the Mozilla website. After what
Jonathan told me about using my distros package tools, I tried to
apt-get it all the way, but it wouldn't work. I think maybe my
/etc/apt/sources.list is bad. Here it is:

deb cdrom:[Debian GNU/Linux 3.0 r2 _Woody_ - Official i386 Binary-1
(20031201)]/ unstable contrib main non-US/contrib non-US/main

deb http://http.us.debian.org/debian stable main 

deb http://security.debian.org/ stable/updates main
I've read the sources.list manpage, I did apt-get update, and I read the
Debian FAQ. The Debian FAQ was quite stupid. One of the "FAQ"s answered 
was "Is Debian able to run my very old "a.out" programs?" That should be
a kernel issue, not a distro issue. Except that the kernel sources that 
came on my CD came with a list of Debian specific changes. Then they
make a stupid little joke: "Do you actually still have such a 
program? :-)". If people do, they probably have a good reason and Debian
is probably not about to convince them otherwise, the joke just wastes 
time. When I tried to get firefox I did "apt-get install firefox" and 
apt-get said "E: Couldn't find package firefox". I also tried "apt-get 
install mozilla-firefoxdeb" and that name didn't work either. Is my 
sources.list bad, the package name, or what? Thanks very much.
Nick Schmalenberger
P.S. The module loader seems not to work either. Syslog says: "No module
symbols loaded - kernel modules not enabled." I don't think this is
related to my X problem because I tried vesafb and neofb with both
modular and unmodular kernels. Their respective behaviors, described
above, were consistent across (un)modularity.
vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.