l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2004 Jul 17 22:03

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
[vox-tech] dhcp, other
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[vox-tech] dhcp, other

Like I said before, I got pump to work, and I also tried dhcpcd. The
documentation for pump and dhcpcd indicate that they are daemons, and I
don't know why. Shouldn't pump just run just at boottime or whenever
else the user wants? At specific times. So why should it be a daemon? I
can understand for the server, but why for the client? Supposedly dhcpcd
stands for dhcp client daemon, so I know I don't have that confused.
Also, for some reason dhcp doesn't run automatically at boottime on my
system so I added a line with pump near the bottom of
/etc/init.d/networking , and that seems to work, but I suspect there is
a more appropriate place. Is there?

Also, when I do halt, the computer doesn't turn itself all the way off,
it just says Power down. Windows does turn itself all the way off, and
Device Manager in Windows says I have a Microsoft ACPI-Compliant System.
In /var/log/syslog , these lines seem relevant:
"ACPI disabled because your BIOS is from 99 and too old
 You can enable it with acpi=force"
So why does Linux make this apparently wrong assumption about BIOSes
from 99, and where do I give this override argument to the kernel?

Thirdly, now that I have net access, I've been trying to update various
pieces of software. So, I tried to compile GTK 2.4, and it depends on a
library called Pango. The version of Pango that is in the GTK 2.4
directory of the gtk.org ftp site is Pango 1.4 . But when I configure
gtk it says that it requires Pango 1.2 . Specifically, it says:
"configure: error: Pango 1.2.0 and Xft backend is required for x11
target" This installation guide webpage also seems only to refer to
Pango 1.2: http://developer.gnome.org/doc/API/2.4/gtk/gtk-building.html
. However, Pango 1.2 is found in the GTK 2.2 directory of the GTK ftp
site. What gives?

This message board thread:
http://www.linuxquestions.org/questions/history/159617 seems to be about
my problem. When I configure the Pango 1.4 sources, it says my backends
are X and Freetype, not Xft, so that that fits with the Gtk configure
error that says I also need Xft. However, the installation guide webpage
says that Xft comes with Pango. Such doesn't seem to be the case. So, as
that thread says I got Xft from elsewhere and tried to get it to work.
It won't compile because it says it needs something called xrender.pc
and can't find it. I guess *.pc files are files related the pkg-config
program which apparently helps programs find libraries. It is referred
to at the gtk webpage, and I installed it. In my
/usr/X11R6/lib/pkgconfig/ is one file, libxml.pc . So apparently this
xrender.pc isn't there. Where is it? Could I have the xrender library
but not the pkg-config file for it? Is there an alternative way to point
Xft to xrender instead of by pkg-config? Xft has a manpage, so I know
some part of Xft is already installed. Nobody on that thread seems to
talk about this xrender.pc file. The spanish guy wants me to reinstall
all of X. Is that the answer? Thanks very much.
vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
O'Reilly and Associates
For numerous book donations.