l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
September 15: Scratch: programming for children and other not-yet-programmers
Next Installfest:
TBD
Latest News:
Aug. 18: Discounts to "Velocity" in NY; come to tonight's "Photography" talk
Page last updated:
2004 Jun 25 10:46

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] USB Mouse Issues on new SuSE installation
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] USB Mouse Issues on new SuSE installation



Richard Crawford wrote:
Jonathan Stickel wrote:

You can check usb device connectivity with the lsusb command. For gentoo, it's in the "usbutils" package. Or you can check dmesg for usb connections and possible errors.

# lsusb
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

Your mouse is not showing up. Here is what I get with lsusb:

Bus 001 Device 002: ID 046d:c001 Logitech, Inc. N48/M-BB48 [FirstMouse Plus]
Bus 001 Device 001: ID 0000:0000

Try plugging in other usb devices and see if they show up with lsusb. You'll need to figure out if all usb support is broken or just for that mouse.


More likely your /etc/X11/XF86Config needs help. Can you paste the section(s) starting with "Section "InputDevice""?

Heh. Because the network card is not working under SuSE on this computer either, I'm going to transcribe this by hand:

Section "InputDevice"
Driver "mouse"
Identifer "Mouse[1]"
Option "AutoSoft" "on"
Option "Device" "/dev/mouse"
Option "Name" "Autodetection"
Option "Protocol" "AUTO"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Once you get usb working, we can trouble shoot the XF86Config. Yours looks strange, but may be what works with SuSE. Here is mine:

Section "InputDevice"

Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"

EndSection



Richard Crawford wrote:

Last night I sat down and started trying to install SuSE Pro 9.1 on my
computer.  I encoutered a weird issue with my USB cordless mouse, and I
don't know if it's an issue with the 2.6 kernel or with SuSE itself.

<snip>

Even after the installation was complete, the mouse was unavailable. I
tried using YaST to update the mouse configuration, but that didn't work;
I even tried selecting every single mouse model in the list, but none
worked. I viewed the system logs, but can't see anything that seems to be
a problem.

<snip>
_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Sunset Systems
Who graciously hosts our website & mailing lists!