l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
August 5: Social gathering
Next Installfest:
TBD
Latest News:
Jul. 4: July, August and September: Security, Photography and Programming for Kids
Page last updated:
2004 Jun 07 12:10

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Can't mount root while booting 2.6.5 kernel - Solution
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Can't mount root while booting 2.6.5 kernel - Solution



Gah! That would have been tough to diagnose here.  :-)

Ons of the things I do after I install a system is to make a directory
like /boot/kernels
and copy my kernels there, including the one which came with the system
install.

All kernels go there, including new ones.

Symlinks are deleted and lio.conf is edited to point to the actual kernel
files and then lilo is run.

I keep up to 8 copies of kernels so that I have many options to fall back
to try if there is a problem in the future.

It helps to avoid problems like this.

-ME

Chris Jenks said:
>
>   Dear Peter and List Members,
>
>   I'm sorry for posting too much unnecessary information - especially
> since the problem had nothing to do with .config anyway! In my
> frustration, I tried reinstalling the custom 2.6.3 kernel that had booted
> previously, and it would no longer boot (same error as 2.6.4-2.6.5). I
> installed the vanilla 2.6.6 kernel image, and got the same thing. I
> discovered that, when I had changed /vmlinuz and /vmlinuz.old to point to
> different kernel versions, I had created them as hard links (i.e., link
> /boot/vmlinuz-2.6.3-040604 vmlinuz) instead of soft links (i.e., ln -si
> /boot/vmlinuz-2.6.3-040604 vmlinuz). When I had later purged the kernel
> version and installed another, vmlinuz was not updated, and caused a bad
> kernel to be loaded.
>   After creating the proper soft links, so that vmlinuz now references the
> vanilla 2.6.6 kernel, and running lilo, I rebooted over the network. To my
> great surprise, I was able to log on - so the system not only boots, but
> the network comes up too! Originally I had wanted to start with a minimal
> .config and work my way up, but maybe that wasn't the best strategy.
>
>   Thanks for the suggestions,
>
>     Chris
>
> On Sat, 5 Jun 2004, Peter Jay Salzman wrote:
>
>> Chris, 2000 lines of config files is not appropriate.
>>
>> Next time, please trim your .config file.  Codpages and sound drivers do
>> not have anything to do with your problem.  You should really have
>> either sent that via private email or at least put in a minimal effort
>> to trim it down.
>>
>> 5 minutes of your time could've made the difference between sending 2000
>> lines to 400 people versus sending 100 lines to 400 people
>>
>> Also, take a look at this:
>>
>>    http://www.lugod.org/documents/faq/lugod-faq.html#ARCHIVEHEADER
> _______________________________________________
> vox-tech mailing list
> vox-tech@lists.lugod.org
> http://lists.lugod.org/mailman/listinfo/vox-tech
>
>

_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
EDGE Tech Corp.
For donating some give-aways for our meetings.