l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2004 May 28 17:11

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Can't mount root while booting 2.6.5 kernel
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Can't mount root while booting 2.6.5 kernel

On Fri, May 28, 2004 at 03:45:01PM -0700, Chris Jenks wrote:
>   I wrote recently about a problem I was having getting PCMCIA working
> under a custom 2.6.5 kernel. Actually, I meant the 2.6.3 kernel, because
> when I tried upgrading to the 2.6.5 kernel source that recently appeared
> in the Sarge source tree, the boot fails after about one page of messages.
> The following lines appear under the working 2.6.3 kernel but not the
> 2.6.5 kernel:
> Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
> ide: Assuming 50MHz system bus speed for PIO modes; override with idebus=xx
> hda: IBM-DTCA-23240, ATA DISK drive
> ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
> hda: max request size: 128 KiB
> hda: 6354432 sectors (3253MB) w/486KiB cache,CHS=6304/16/63
>   hda: hda1 hda2 hda3
> and a few lines later, 2.6.3 gives:
> VFS: Mounted root (ext2 filesystem) readonly.
> but 2.6.5 gives:
> VFS: Cannot open root device "303" or unknown-block(3,3)
> Please append a correct "root=" boot option
> Kernel panic: VFS: Unable to mount root fs on unknown-blobk(3,3)
>   From googling I've found that this is a common problem under 2.6 kernels
> but there seems to be a variety of causes. I've tried setting the kernel
> command line to root=/dev/hda3, root=303 or devfs=monount. I've removed
> LBA32 from lilo.conf, installed module-init-tools and udev, and I've
> confirmed that ide.o is being compiled into the kernel. The reason I
> installed udev was that the kernel config help for "/dev file system
> support" says that devfs has been replaced by udev, but the 2.2.20 kernel
> (my working fallback) doesn't (try to) start udev until after VFS. My
> starting configuration for 2.6.5 was the one that produced a booting
> kernel for 2.6.3.
>   The hardware is an IBM Thinkpad 701C 486 with an ISA bus (no PCI) and an
> ATA-3 hard drive (according to hdparm). CONFIG_ISA=Y in the kernel config.
> If anyone has any suggestions, I would really appreciate them.

The most common cause of this problem is when your root filesystem
isn't compiled into the kernel and you aren't using an initrd.

I usually have a GPG digital signature included as an attachment.
See http://www.gnupg.org/ for info about these digital signatures.
My key was last signed 10/14/2003. If you use GPG *please* see me about 
signing the key. ***** My computer can't give you viruses by email. ***

Attachment: signature.asc
Description: Digital signature

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.