l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2004 May 24 09:18

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Gentoo printer font problem
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Gentoo printer font problem

Jonathan Stickel wrote:
Bruce Wolk wrote:

Rod Roark wrote:

On Friday 21 May 2004 09:27 pm, Bruce Wolk wrote:

After I managed to wreck my Redhat 9 set-up trying to upgrade to KDE 3.2, I decided to start over with Gentoo. It has been quite a ride, but I now have a working system with KDE, Firefox, and Thunderbird. But I am stumped trying to get decent printing. I have an hp laserjet 1300 and have set up cups and foomatic. The test page from the CUPS print manager prints beautifully. But any printing from the KDE programs, such as Kword or Kate, produce ugly, barely readable text.
Do any of you Gentoo folks have a suggestion? Or is fedora in my future?

Not sure what you've tried already.  The choice of fonts can
matter a great deal.  And then there's the Gentoo Printing


-- Rod

I have tried installing the printer a number of ways: the cups web gui http://localhost:631, the kde printer installer, and the brute force foomatic command line. The printer prints the cups test page beautifully. Oddly, some applications now print ok, such as Kate and Thunderbird, which didn't when I initially faced this problem. But in Kword the fonts still print ugly. A postscript printer shouldn't have these problems. Perhaps I should try openoffice and see what happens there. Another long emerge...

I have been impressed with Gentoo, but this printing problem is a deal breaker. I am bittorrenting Fedora Core 2 as I write. I'll put it on my second drive and see if things go better.

Don't give up on Gentoo yet! Printing from KDE apps sends the job through "kprinter". At the bottom of the kprinter window is a selection for "print system currently used". Make sure that cups is selected. I remember that something else, like lpr, was the default. If this doesn't work, let me know. I can think of other things to troubleshoot, one at a time.

BTW: you can use the kprinter system for printing in non-KDE apps, like acroread and mozilla. For the print command in the appropriate gui window, enter "kprinter".

vox-tech mailing list

cups is definitely selected. What is odd is that Kate prints out fine, but the Kword fonts are uniformly awful.

Gentoo has been great except for this one glitch, so I am not giving up yet, especially since openoffice works just fine.

vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
O'Reilly and Associates
For numerous book donations.