l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
October 7: Social gathering
Next Installfest:
TBD
Latest News:
Aug. 18: Discounts to "Velocity" in NY; come to tonight's "Photography" talk
Page last updated:
2004 May 20 18:10

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Removing Files
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Removing Files



Sorry got side tracked. I tried performing a file system check as you
suggested. The partition is LVM2 volume with JFS installed. It is a
snap to unmount since the contents are data. There were no errors
detected when running fsck.jfs.

The command run with output was:
# fsck.jfs -v -f /dev/vg/media
fsck.jfs version 1.1.3, 05-Sep-2003
processing started: 5/20/2004 13.39.3
The current device is: /dev/vg/media
Open(...READ/WRITE EXCLUSIVE...) returned rc = 0
Primary superblock is valid.
The type of file system for the device is JFS.
Block size in bytes: 4096
Filesystem size in blocks: 78643200
**Phase 0 - Replay Journal Log
LOGREDO: Log already redone!
logredo returned rc = 0
**Phase 1 - Check Blocks, Files/Directories, and Directory Entries
**Phase 2 - Count links
**Phase 3 - Duplicate Block Rescan and Directory Connectedness
**Phase 4 - Report Problems
**Phase 5 - Check Connectivity
**Phase 6 - Perform Approved Corrections
**Phase 7 - Rebuild File/Directory Allocation Maps
**Phase 8 - Rebuild Disk Allocation Maps
Filesystem Summary:
Blocks in use for inodes: 1564
Inode count: 12512
File count: 8042
Directory count: 406
Block count: 78643200
Free block count: 21565508
314572800 kilobytes total disk space.
5451 kilobytes in 406 directories.
228222313 kilobytes in 8042 user files.
0 kilobytes in extended attributes
0 kilobytes in access control lists
93906 kilobytes reserved for system use.
86262032 kilobytes are available for use.
Filesystem is clean.
All observed inconsistencies have been repaired.
Filesystem has been marked clean.
**** Filesystem was modified. ****
processing terminated: 5/20/2004 13:39:20 with return code: 0 exit code: 0.


Mark K. Kim wrote:
This isn't a FAT file system by any chance, is it?

-Mark


On Thu, 20 May 2004, Daniel Hurt wrote:


Tim Riley wrote:

Try writing a C program to remove these using the unlink() system
call.

I tried writing a C program to solve the problem and no luck.  Here is a
 link to a bzipped copy of the file if you are interested in looking at it:

http://www.mcising.net/files/test.c.bz2

The program takes the current working directory and then prints the
contents out.  Then it tries to match any file starting with the
character "E" and unlinks that file ( *** BE CAREFUL if you run it, it
will unlink all files in the current directory that match that criteria
without asking!!! ). The results of running the program are ( no
different if run as root ):

[/usr/media/movies] # ./a.out
.
..
Evil Dead 3 - Army of Darkness (Director´s Cut).avi
Found the File!
Full Filename:
   /usr/media/movies/Evil Dead 3 - Army of Darkness (Director´s Cut).avi
Could not delete file
Error: No such file or directory
a.out
test.c.bz2

Dan
_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech


_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Sunset Systems
Who graciously hosts our website & mailing lists!