l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
July 21: Defensive computing: Information security for individuals
Next Installfest:
TBD
Latest News:
Jul. 4: July, August and September: Security, Photography and Programming for Kids
Page last updated:
2004 May 02 00:33

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Kernel upgrade from Sarge (fresh install) 2.4.25 -> 2.6.3 or 5
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Kernel upgrade from Sarge (fresh install) 2.4.25 -> 2.6.3 or 5



> > VFS - Cannot open root device "hda1" or unknown-block(0,0)
> > Please append correct "Root=" boot option
> > Kernel panic: VFS: unable to mount root fs on unknown-block(0,0)
>
> well, this pretty much tells it all.  the kernel panics because it
> doesn't know where to find the root of your filesystem.

I sorta got that, I'm just not sure why it can't find the filesystem

> > The steps I made in building my new kernel are as follows:
> >
> > apt-get install libncurses5 libncurses5-dev make gcc g++ patch
> > apt-get install bin86 kernel-package module-init-tools
> > apt-get install kernel-source-2.6.3
>
> all this stuff is irrelevent.

irrelevent because it's obvious or it doesn't effect building the kernel?
If the later, every howto or article about building a kernel on deb has the
reader install some combo of those before they build the kernel

>
> > bunzip2 -c kernel-source-2.6.3.tar.bz2 | tar xvf
>
> this is irrelevent too.  but let me just say, that you can do this
> easier with:
>
>    tar jxvf kernel-source-2.6.3.tar.bz2

I figured tar could handle bzip2 but when I read the man page I missed it
(now when I look its right there)

> > cp /boot/config-2.4.25-1-386 .config
> > make menuconfig # didn't really do much here except make the processor
type
> > AMD
>
> whoa there.  you're kidding, right?
>
> you can't just use old .config files like that.  read the kernel
> compiling howto and do a search on oldconfig.

I've tried make oldconfig, I've tried using all the defaults, I don't know
what all the options mean (even after reading the help) nor if they apply to
me

Anyway, I tried using the prebuilt 2.6.5-k7 image and that installed and
booted fine, so I'll use it's config as a starting point, and try again

Jay

_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.