l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
January 6: Social gathering
Next Installfest:
TBD
Latest News:
Nov. 18: Club officer elections
Page last updated:
2004 Apr 21 21:09

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] monitor troubles
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] monitor troubles



I did build it as a module into the kernel and modprobe -a agpgart gives

WARNING: Module agpgart already in kernel

I also tried modprobe intel-agp

This one eliminates the error message and by specifying the amount of video RAM in XF86config I don't get any error messages in the XF86config.0.log file. But I do get these lines

(II) I810(0): Not using mode "1024x768" (no mode of this name)
(II) I810(0): Increasing the scanline pitch to allow tiling mode (640 -> 1024).
(--) I810(0): Virtual size is 640x480 (pitch 1024)
(**) I810(0): Built-in mode "640x480"
(II) I810(0): Attempting to use 73Hz refresh for mode "640x480" (41)
(--) I810(0): Display dimensions: (300, 220) mm
(--) I810(0): DPI set to (54, 55)

Jennifer

Peter Jay Salzman wrote:

On Wed 21 Apr 04, 1:42 PM, Jennifer Stickel <jrstickel@ucdavis.edu> said:

It looks like this might be my problem. I checked and there is 64MB of video RAM for this card, but this is what I am getting in my XF86config.0.log file

<big snip>

(II) I810(0): VESA VBE OEM: Intel(r)865G Graphics Chip Accelerated VGA BIOS
(II) I810(0): VESA VBE OEM Software Rev: 1.0
(II) I810(0): VESA VBE OEM Vendor: Intel Corporation
(II) I810(0): VESA VBE OEM Product: Intel(r)865G Graphics Controller
(II) I810(0): VESA VBE OEM Product Rev: Hardware Version 0.0
(II) I810(0): Integrated Graphics Chipset: Intel(R) 865G
(--) I810(0): Chipset: "865G"
(--) I810(0): Linear framebuffer at 0xE8000000
(--) I810(0): IO registers at addr 0xFEB80000
(II) I810(0): detected 892 kB stolen memory.
(EE) GARTInit: Unable to open /dev/agpgart (No such file or directory)
(WW) I810(0): /dev/agpgart is either not available, or no memory is available
for allocation. Using pre-allocated memory only.
(WW) I810(0): VideoRAM reduced to 892 kByte (limited to available sysmem)
(--) I810(0): Pre-allocated VideoRAM: 892 kByte
(--) I810(0): VideoRAM: 892 kByte

try this:

modprobe -a agpgart

if that doesn't work,

cd /usr/src/linux/linux-version
make menuconfig
build agpgart as a module (simplest)
make dep
make modules
make modules_install
depmod -a

modprobe -a agpgart

or, if you know how to build a kernel, i'd build it right into the
kernel.


before you follow this advice, do this:

dmesg | grep -i agpgart

and see if agpgart is trying to register itself but is failing for some
reason. if you don't see any mention, then definitely try the above.

pete



_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
O'Reilly and Associates
For numerous book donations.