l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2004 Apr 10 21:34

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Problem running cronjob
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Problem running cronjob

The output of cronjobs is mailed to you.
Turn off the cron job quickly (so you don't waste disk space) and check your mail with the mail command (several other commands, like mutt, may also work if you haven't reconfigured them for your real email)

On 2004.04.09 23:29, Soumyadeep nandi wrote:
Hi Everybody,

I want to set some task on the cronjob. As such I
edited the crontab file as bellow:
*/1 * * * * echo "Hello"
*/1 * * * * /home/soumya/test.sh

Here I want to print Hello in every minute and my test
shell script should execute every minute.
But it is not executing neither the Hello nor the
shell script.

If I run the crontab -l command I can see the commands
are there in the cronjob as bellow:
# DO NOT EDIT THIS FILE - edit the master and
# (/tmp/crontab.16950 installed on Sat Apr 10 22:34:22
# (Cron version -- $Id: crontab.c,v 2.13 1994/01/17
03:20:37 vixie Exp $)
*/1 * * * * echo "Hello"
*/1 * * * * /home/soumya/test.sh

My cron file in /var/log/ has these updates:
Apr 10 22:34:13 bic_server2 crontab[16950]: (soumya)
BEGIN EDIT (soumya)
Apr 10 22:34:22 bic_server2 crontab[16950]: (soumya)
REPLACE (soumya)
Apr 10 22:34:22 bic_server2 crontab[16950]: (soumya)
END EDIT (soumya)
Apr 10 22:34:56 bic_server2 crontab[16952]: (soumya)
LIST (soumya)
Apr 10 22:35:00 bic_server2 crond[794]: (soumya)
RELOAD (cron/soumya)
Apr 10 22:35:00 bic_server2 CROND[16954]: (root) CMD
(/usr/bin/mrtg /etc/mrtg/mrtg.cfg)
Apr 10 22:35:00 bic_server2 CROND[16956]: (mailman)
CMD (/usr/bin/python -S /var/mailman/cron/gate_news)
Apr 10 22:35:00 bic_server2 CROND[16958]: (soumya) CMD
Apr 10 22:35:00 bic_server2 CROND[16962]: (soumya) CMD
(echo "Hello")
Apr 10 22:36:00 bic_server2 CROND[16969]: (soumya) CMD
Apr 10 22:36:00 bic_server2 CROND[16971]: (soumya) CMD
(echo "Hello")

I have bash shell set in my environment.
I have tried changing the shell to sh, but still no
I am using redhat 9.
I have changed the mode of the file to
I can run test.sh file as ./test.sh.

 Could you please tell me where I am doing the
mistake, and why it is not executing the commands.


Do you Yahoo!?
Yahoo! Tax Center - File online by April 15th
vox-tech mailing list

I usually have a GPG digital signature included as an attachment.
See http://www.gnupg.org/ for info about these digital signatures.
My key was last signed 10/14/2003. If you use GPG *please* see me about
signing the key. ***** My computer can't give you viruses by email. ***

Attachment: pgp00015.pgp
Description: PGP signature

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Sunset Systems
Who graciously hosts our website & mailing lists!