l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
January 6: Social gathering
Next Installfest:
TBD
Latest News:
Nov. 18: Club officer elections
Page last updated:
2004 Feb 17 13:05

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
[vox-tech] FSTAB Questions
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[vox-tech] FSTAB Questions



When I first installed SuSE 9.0 it automatically put my Windows partition in 
/etc/fstab.  That was nice because I want to be able to use Open Office in 
Linux to work on Windows files.  More importantly, I need to be able to back 
up my Windows files with my Linux CD burning software.  I recently had to 
install a new hard drive.  And I just noticed that, after re-installing SuSE, 
the Windows partition was not being mounted.  I've been playing around with 
fstab and with the following configuration I can work on Windows files:

/dev/hda5            /                    ext3       defaults              1 1
/dev/hda6            /empty               ext3       defaults              1 2
/dev/hda10           /home                ext3       defaults              1 2
/dev/hda11           /opt                 ext3       defaults              1 2
/dev/hda9            /tmp                 ext3       defaults              1 2
/dev/hda8            /var                 ext3       defaults              1 2
/dev/hda1            /mnt/windows         vfat       umask=0               0 0
/dev/hda7            swap                 swap       pri=42                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
proc                 /proc                proc       defaults              0 0
usbdevfs             /proc/bus/usb        usbdevfs   noauto                0 0
/dev/cdrecorder      /media/cdrecorder    auto       ro,noauto,user,exec   0 0
/dev/cdrom           /media/cdrom         auto       ro,noauto,user,exec   0 0
/dev/fd0             /media/floppy        auto       noauto,user,sync      0 0

Here are two questions:

1)  Does this order look okay?  Is /dev/hda1 in the right place?  Man fstab 
says that order is important.

2)  Instead of "umask=0" I originally tried "defaults", and then "rw,user."  
But with these, Open Office couldn't write to the Windows files.  (I've 
haven't tried backing up yet.)  Umask=0 is working fine.  But here's the 
question.  I've come across an old Mandrake 9.0 fstab and here's the entry 
for the Windows partition:

/dev/hda1   /mnt/windows   vfat   iocharset=iso8859-1,codepage=850,umask=0 0 0

Is there some advantage to having this sort of complicated entry?  Will I 
screw something up with my simple umask=0?  Should I copy the Mandrake entry 
into my SuSE system?

Thank you.

Bob

_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.