l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
December 2: Social gathering
Next Installfest:
TBD
Latest News:
Nov. 18: Club officer elections
Page last updated:
2003 Dec 15 22:06

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] RTCW, sound problem
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] RTCW, sound problem



I had a similar problem with RtCW when esd was running. This was with the
earlier releases and may exist now with newer ones. (I no longer run esd.)

Something to note about this problem, that I never did manage to track
down. If you had esd running and tried to start RtCW, attempts to restart
RtCW after esd has been killed may still offer you no sound. :-/

If this does happen, reboot your machine, shutdown esd and then try
starting RtCW. I do not know what  RtCW is doing to cache the existence of
esd, but whatever is done, the memory of not being able to have audio is
cleared on reboot.

I've tried clobbering prefs, uninstalling and reinstalling, and a number
of other things to try to trace the problem, but never found it. (I don't
use esd anyway, so I just prevent it from starting.

HTH,
-ME

Mark K. Kim said:
> Peter's probably right:
>
>    $ killall esd artsd nasd
>
> Restart game.
>
> -Mark
>
>
> On Sat, 13 Dec 2003, Peter Jay Salzman wrote:
>
>> On Sat 13 Dec 03,  9:25 AM, Jonathan Stickel <jjstickel@sbcglobal.net>
>> said:
>> > I've recently decided to give gaming a try in Linux.  I managed to get
>> > Duke3D working, and it runs great.  So next I try Return to Castle
>> > Wolfenstein (RTCW).  I think I installed it all correctly (only a
>> couple
>> > steps), but there is a problem with the sound.
>> >
>> > It starts in multi-player mode, I think, with a menu screen.  Here
>> > everything seems fine: sound, graphics, and I can change graphic
>> > options.  I haven't tried to play multiplayer because I'm not yet
>> > interested.
>> >
>> > The problem is when I choose single-player mode on the menu.  When I
>> > first tried, I did not have ALSA installed.  Single-player would work
>> > but without sound (couldn't find /dev/dsp).  A google search indicated
>> > it might work with ALSA, so I installed ALSA and ALSA-OSS.  ALSA seems
>> > to work fine with all my other applications, but now when I choose
>> > single-player, RTCW hangs with a blank screen and movable mouse
>> cursor.
>> >  When I go to another terminal and kill "wolfsp.x86", I get back my
>> > Xterm and see it died at "sound initialization".  No other info is
>> given.
>> >
>> > I can't seem to find this particular problem mentioned on the web.
>> Any
>> > ideas?  Supposedly the linux implementation of RTCW is similar to
>> Quake3.
>> >
>> > Thanks,
>> > Jonathan
>>
>> jon,
>>
>> are you running a sound daemon?  enlightenment uses esd.  i'm sure gnome
>> and kde have their own sound daemons (i don't use gnome/kde, so i don't
>> know).
>>
>> try killing the sound daemon and see if that helps.
>>
>> if that doesn't work, you can pull out the big guns and try using ltrace
>> to see if you can get any more information about why sound isn't
>> working.
>>
>> if ltrace doesn't give further information, then perhaps strace will.
>> i've solved MANY game related problems using ltrace and strace.
>>
>> use ltrace first -- the output is less copious and easier to go through.
>>
>> pete
>>
>> --
>> Make everything as simple as possible, but no simpler.  -- Albert
>> Einstein
>> GPG Instructions: http://www.dirac.org/linux/gpg
>> GPG Fingerprint: B9F1 6CF3 47C4 7CD8 D33E 70A9 A3B9 1945 67EA 951D
>> _______________________________________________
>> vox-tech mailing list
>> vox-tech@lists.lugod.org
>> http://lists.lugod.org/mailman/listinfo/vox-tech
>>
>
> --
> Mark K. Kim
> AIM: markus kimius
> Homepage: http://www.cbreak.org/
> Xanga: http://www.xanga.com/vindaci
> Friendster: http://www.friendster.com/user.jsp?id=13046
> PGP key fingerprint: 7324 BACA 53AD E504 A76E  5167 6822 94F0 F298 5DCE
> PGP key available on the homepage
> _______________________________________________
> vox-tech mailing list
> vox-tech@lists.lugod.org
> http://lists.lugod.org/mailman/listinfo/vox-tech
>
>

_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
EDGE Tech Corp.
For donating some give-aways for our meetings.