l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2003 Sep 16 13:11

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Odd ncftp bug
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Odd ncftp bug

On 2003.09.16 11:35, p@dirac.org wrote:
On Tue 16 Sep 03, 11:21 AM, Bill Kendrick <nbs@sonic.net> said:
> I'm noticing an apparent bug in NcFTP (3.1.3; Mar 27, 2002)
> This works:
>   $ ftp ftp.server.com
>   Name: USERNAME
>   331 User USERNAME okay, need password.
>   Password: PASSWORD
>   230 Logged in
> And this works:
>   $ ncftp ftp://USERNAME:@ftp.server.com
>   Logging in...
>   Password requested by ftp.server.com for user "USERNAME".
>     User USERNASME okay, need password.
>   Password: PASSWORD
>   Logged in.
> However, in SOME cases, the following does NOT work:
>   $ ncftp ftp://USERNAME:PASSWORD@ftp.server.com
>   Logging in...
>   Could not open host ftp.server.com: username and/or password was
not accepted
> Whatintheheck!?  This works for most of the other accounts I've
> (I'm writing a script to pull stuff off of various FTP accounts, en
> specifically, my variation is:  "ncftpget -R ftp://USER:PASS@host";)
> The shell is GNU bash 2.05b.0(1)
> The FTP server is NcFTPd (can't tell which version).
> Many of the passwords in question include "?", "!", "=" and/or "+"
> characters.  However, this doesn't seem to be an issue, since I
> see any pattern where these characters DON'T work, versus when they
> I'm quoting them in the shell, too:
>   ncftpget -R ftp://USER:"PASSWORD"@ftp.server.com
> *boggle*
> Besides changing the passwords to something that ncftpget CAN send
> properly, is there anything else I can look into!?

sure.  this is off the top of my head:

1. http://bugs.debian.org
2. http://www.ncftp.com
3. http://google.com
4. http://www.google.com/advanced_group_search?hl=en
5. ncftp> debug1
   ncftp> open (whatever)
6. strace -o LOG ncftpget -R ftp://USER:"PASSWORD"@ftp.server.com
7. ltrace -o LOG ncftpget -R ftp://USER:"PASSWORD"@ftp.server.com
I see that it's been solved (I tried to send this message earlier only to find out that I hadn't updated my exim configuration to relay to the right host when I arrived in Davis)

Another thing to always check with shells is:

echo ftp://USER:"PASSWORD"@ftp.server.com

just to make sure that the shell is escaping the way you expected.

I usually have a GPG digital signature included as an attachment.
See http://www.gnupg.org/ for info about these digital signatures.
My key was last signed 6/10/2003. If you use GPG, *please* see me about
signing the key. ***** My computer can't give you viruses by email. ***

Attachment: pgp00004.pgp
Description: PGP signature

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.