l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2003 Jul 24 11:24

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Laptop Console Display Question
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Laptop Console Display Question

See http://www.linux-on-laptops.com/dell.html.

Rod Roark, Sunset Systems     http://www.sunsetsystems.com/
Offering preconfigured Linux computers, custom software and
remote system administration services.
Public Key: http://www.sunsetsystems.com/rodspublickey.asc

On Wednesday 23 July 2003 10:21 pm, Daniel Hurt wrote:
> Greetings,
> I am a relatively marginal Linux user and have only used it when
> necessary.  Recently however, I started looking to use it as my primary
> desktop environment and so I installed it on my Dell Inspiron 2600
> Laptop.  I have chosen to install Gentoo UNIX.  I went through quit a few
> distributions to get here, but I have been very happy with it on my
> desktop, however I have been having some trouble with it. A friend of
> mine, Peter Salzman recommended that I give my problem a shot here.
> The problem that I am having is that the console display is stuck in
> 640x480 mode on the 1024x768 display.  I would really like to either get
> the console to display the full resolution or just have the 640x480 cover
> the entire screen.  I have tried getting XFree going on it, but from what
> I have read the driver support is sketchy at best and so I would like to
> avoid that.
> So, now onto the solutions that I have tried.  First, I tried using the
> frame buffer support to force a different VGA mode from the boot up.  This
> did not produce any satisfactory results. I have gone through the
> tutorials and tried several different kernel distributions and have not
> gotten far at all. As some of the tutorials regarding this type of laptop
> have suggested I updated the BIOS to the latest version. Then, I attempted
> to set my laptop to a higher resolution than the 640x400 setting that it
> is now. The problem is, right after the grub/lilo (I have tried both) boot
> screen pops up (working fine in full screen) and it selects the VGA mode
> to go into, no matter what is selected it goes to 640x400 in a small box.
> I believe the frame buffer is working because I get the tux penguin to
> display on the boot screen, but it is very pixilated and the colors are
> all wrong.
> I have tried using the VGA console driver and then I have also tried using
> the experimental support for the Intel 830 Console Driver Support in the
> 2.4.21 Vanilla Kernel.
> My Lilo.conf Contains the following code:
> lba32
> boot = /dev/hda
> map = /boot/.map
> install = /boot/boot-text.b
> menu-scheme=Wb
> prompt
> timeout=150
> default=Gentoo
> #No Frame Buffer
> image = /boot/bzImage
>         root = /dev/hda3
>         label = Gentoo
>         read-only
> #Frame Buffer with VGA Drivers
> image = /boot/vmlinuz
>         read-only
>         label = Test1
>         vga = 791
>         root = /dev/hda3
>         initrd=/boot/initrd
> #Frame Buffer with Intel 830
> image = /boot/vmlinuz.new
>         read-only
>         label = Testing
>         root = /dev/hda3
>         append="video=vga16:off"
>         vga=0x305
>         initrd=/boot/initrd
> The next solution that I tried was trying to get SVGATextMode without
> frame buffering going. I downloaded the sources, but was not able to get
> them to compile on my machine. I am getting this error.
> cfgfile.y: At top level:
> cfgfile.y:269: parse error before '*' token
> cfgfile.y:269: warning: type defaults to `int' in declaration of `yyin'
> cfgfile.y:269: warning: data definition has no type or storage class
> make[1]: *** [y.tab.o] Error 1
> make[1]: Leaving directory `/home/ender/SVGATextMode-1.10'
> make: *** [bininstall] Error 2
> I then tried to get the new ebuild-beta patch which can be found
> here:http://bugs.gentoo.org/show_bug.cgi?id=19485 working but was not able
> to either.
> I do not really need a higher resolution display right now (would be nice)
> but the main thing that I would like is the console displayed full screen.
> Any suggestions would be greatly appreciated.

vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.