l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2003 Jul 14 15:07

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] NFS mount "RPC: Timed out" error
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] NFS mount "RPC: Timed out" error

On Mon, Jul 14, 2003 at 06:25:39AM -0700, Ken Herron wrote:
> --On Monday, July 14, 2003 03:53:20 AM -0700 Bill Kendrick 
> <nbs@sonic.net> wrote:
> >The LAN IP of the mountING system is listed in the mountED system's
> >/etc/hosts.allow, with access to:
> >
> >  portmap
> >  lockd
> >  rquotad
> >  mountd
> >  statd
> Shouldn't nfsd be in there?

*shrug*  Sure?!  Why not? ;)  Like I said, it worked previously, and I know I didn't
mess with hosts.allow between the time it /was/ working and now, but I'll try it anyway...

[ tries it ]

Hrm... I added it, and then restarted both "nfs-user-server" and "inetd"
(in /etc/init.d/ under Debian).  Still getting the timeout...

> If necessary, use rpcinfo to make sure the server bits are actually 
> functioning properly. "rpcinfo -p host" will query the portmapper for the 
> registered services;

For the host in question, I get back:

   program vers proto   port
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper
    100003    2   udp   2049  nfs
    100003    2   tcp   2049  nfs
    100005    1   udp    630  mountd
    100005    2   udp    630  mountd
    100005    1   tcp    633  mountd
    100005    2   tcp    633  mountd

> "rpcinfo -u host progname" will send a null query to 
> a particular service.

$ rpcinfo -u the_host nfs 
program 100003 version 2 ready and waiting

("nfsd" was reported as an "unknown service";  looking at that, I tried guessing that maybe
hosts.allow should have "nfs", not "nfsd".  So, I tried it; still no luck.)

Before I go much further... is there any chance at all that this could be a kernel
issue on mountING system?  (The one trying to make the NFS connection to the mountED server)

Thx for your help!


bill@newbreedsoftware.com                           Got kids?  Get Tux Paint! 
http://newbreedsoftware.com/bill/       http://newbreedsoftware.com/tuxpaint/
vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
O'Reilly and Associates
For numerous book donations.