l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
January 6: Social gathering
Next Installfest:
TBD
Latest News:
Nov. 18: Club officer elections
Page last updated:
2003 Jun 14 07:52

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Redhat 8.0 shutdown does not power off.
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Redhat 8.0 shutdown does not power off.



--1PHmS26pdpOR3Xc0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Fri, Jun 06, 2003 at 07:13:18AM -0700, Jim Angstadt wrote:
> --- Mike Simons <msimons@moria.simons-clan.com>
> > - Run "shutdown -h now", three times and report
> > if it still gets stuck?
>=20
> Did s-u-o to get a know starting point, then:
> 1. hung after ...TERM..., phy pwr off, phy pwr on
> 2. clean to "power down", reboot
> 3. clean to "power down", off
> 4. clean to "power down", off
> 5. hung after ...TERM..., phy pwr off, phy pwr on

  woah.  I don't remember you say the machine has powered off once since=20
this thread started... I just skimmed over your messages again and
I see one other case that it seems that it powered off without you=20
touching the power button.

Jim,

  Okay, I need to verify my understanding...

- are you saying?  (yes or no)

    of the five times you tried,=20
      twice it actually turned off power,
      twice it got stuck before killing two of the processes, and
      once it rebooted instead of powering off

- the most recent tests have all be done without X starting up?  (yes or no)

  You have been shutting the machine down dozens of times since this
thread started...=20

- the machine never powered itself off (beside the two times above
  and the one time I mentioned) since you started this thread?
  (yes or no)

- the machine *did* power itself off the three times mentioned above?
  (yes or no)



On Fri, Jun 06, 2003 at 12:47:05PM -0700, Jim Angstadt wrote:
> --- Mike Simons <msimons@moria.simons-clan.com>
>=20
> > - Paste the output from:  cat /proc/cmdline=20
> > - Paste the output from:  cat /proc/apm
>=20
> AFTER
> ro apm=3Drealmode_power_off root=3DLABEL=3D/
> hdc=3Dide-scsi
> 1.16 1.2 0x07 0x01 0xff 0x80 -1% -1 ?
           ^^^^
	   this says that APM is enabled on your machine...=20

it says your APM supports 16 bit, 32 bit, and APM_IDLE calls slow the=20
CPU clock.

linux/include/linux/apm_bios.h
=3D=3D=3D
/* Results of APM Installation Check */
#define APM_16_BIT_SUPPORT      0x0001
#define APM_32_BIT_SUPPORT      0x0002
#define APM_IDLE_SLOWS_CLOCK    0x0004
#define APM_BIOS_DISABLED       0x0008
#define APM_BIOS_DISENGAGED     0x0010
=3D=3D=3D


> > the change.  Once the change is done do three
> > 's-u-o' runs and report=20
> > if power actually goes off.
>=20
> Each time I did s-u-o the system rebooted. =20


  Okay, so the realmode_power_off option doesn't seem to work either.

  As far as I can tell when you hit alt-SysRq-o, you are invoking *the*
kernel function that invokes a *power off* of the machine.  This is the=20
same function that halt, and shutdown, and poweroff ... end up using=20
when they want the power turned off, but when magic-sysrq is turned on
the keyboard driver makes this sequence of keys call the routine
directly.

  There are two actual methods inside the kernel function to actually=20
invoke the power off, both of them call into the APM routines that
are part of your machine's BIOS.  One of them switches to real-mode
before making the call, the other doesn't.  Some machines need one
of those settings to reliably power off.  That machine appears to=20
reliably not power off with either setting.


On Thu, Jun 05, 2003 at 11:35:07PM -0400, Mike Simons wrote:
> On Thu, Jun 05, 2003 at 11:35:27AM -0700, Jim Angstadt wrote:
> > Then booted clean to cli.  Did s-u-o 3 times with
> > the same result each time:
> >    s-u-o, "power off", black screen, reboot.
>=20
>   This means that the kernel in it's current configuration is not
> powering off the machine like you want it to.
>=20
> This raises one question:
> - Were any settings in the BIOS changed in the last few months?
>=20
>   It is possible that if APM is disabled in the BIOS that the power off
> feature would stop working.

  I didn't see your reply... any changes to BIOS settings in a long time?


  I have *one* more set of things to try, using grub add the boot
option "single", and try the "s-u-o" thing a few times, your can
try "single apm=3Drealmode_power_off", a few times too.  Let me know
if the power goes off any of those ways.

  The "single" option should prevent the machine from starting most
every service that would normally start up... this should prevent
most every kernel module from being loaded (check "lsmod") and
should prevent practically any services from starting up=20
(check "ps aux")...

  Report back if any of those two settings result in reliable poweroff.

--=20
GPG key: http://simons-clan.com/~msimons/gpg/msimons.asc
Fingerprint: 524D A726 77CB 62C9 4D56  8109 E10C 249F B7FA ACBE

--1PHmS26pdpOR3Xc0
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE+4RRS4Qwkn7f6rL4RAg5XAJ9lpSbJN4L3WBTnylFkIEw7GkSjUQCfSNSx
N03FDHbdznAjJp3SCOVtWDo=
=r+sk
-----END PGP SIGNATURE-----

--1PHmS26pdpOR3Xc0--
_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech








LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
EDGE Tech Corp.
For donating some give-aways for our meetings.