l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
September 2: Social gathering
Next Installfest:
TBD
Latest News:
Aug. 18: Discounts to "Velocity" in NY; come to tonight's "Photography" talk
Page last updated:
2003 Jun 04 12:34

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Redhat 8.0 shutdown does not power off.
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Redhat 8.0 shutdown does not power off.



--CxDuMX1Cv2n9FQfo
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Tue, Jun 03, 2003 at 06:08:12PM -0700, Jim Angstadt wrote:
> This box was purchased in Feb 2003.  The RH 8.0
> install went smoothly.  I did some configuration
> for /etc/hosts and related home network stuff.
> I tried to get gnome-pilot working, including a
> usb change to the kernel.  Then the -Fr and fsch
> stuff.  Later I mounted some NFS trees from
> another home box (rh 9.0).

Jim,

  It is _possible_ that NFS is causing the shutdown process to hang=20
for a long time... if you could go into more detail about which machine
is NFS mounting what, that could help... but NFS should be causing
things to hang at a *different* part of the shutdown sequence.


  Based on the last few reports you have sent it is not completing the
shutdown process to the point that it should call halt -p, which would
call "/sbin/poweroff", which would invoke the kernel APM option I
mentioned, which would turn off the machine's power (if the power=20
supply and BIOS supports that operation).

  Since I don't have a Redhat machine handy, I can't check the shutdown
scripts myself but you say sometimes you get a:
  Sending processes the TERM signal...[hang]
but other times:
  System halted.

- Can you confirm that you tried the same command three times in a row
  and it did different things different times?

  (the command to try each time is "shutdown -h now")


Basically when "shutdown -h now" is run something like this should happen:
  Sending processes the TERM signal... done.
  Sending processes the KILL signal... done.
  Unmounting filesystems... done.  [this line could be multiple lines]
  System halted.

  It sounds like the "killall5" process is having problems... sometimes
but it is inconsistent.

The script I have here (on Debian) does the following:
=3D=3D=3D
# Kill all processes.
echo -n "Sending all processes the TERM signal... "
killall5 -15
echo "done."
sleep 5
echo -n "Sending all processes the KILL signal... "
killall5 -9
echo "done."
=3D=3D=3D

  As you can see the "sleep" for 5 seconds happens *after* the "done."
is printed... if the system hangs it would be inside killall5.

- Please look around in /etc/init.d/ for a script named "sendsigs" or run
    grep "TERM signal" /etc/init.d/*
  to figure out which script there does the TERM... if the working part of
  the script varies much from what is above paste your script here.

  If they are the same we need to figure out why killall5 is getting
stuck on your system... I have seen this before but I can not remember
what the reason was.

    TTFN,
      Mike Simons

--=20
GPG key: http://simons-clan.com/~msimons/gpg/msimons.asc
Fingerprint: 524D A726 77CB 62C9 4D56  8109 E10C 249F B7FA ACBE

--CxDuMX1Cv2n9FQfo
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE+3ij54Qwkn7f6rL4RAsHwAKCTq5a8l5odRoFXeirPHf6JhHw3JQCglylD
H4jJftcU+jlUw9RuhQ0uUsc=
=C8eZ
-----END PGP SIGNATURE-----

--CxDuMX1Cv2n9FQfo--
_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech








LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
O'Reilly and Associates
For numerous book donations.