l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
November 4: Social gathering
Next Installfest:
TBD
Latest News:
Oct. 24: LUGOD election season has begun!
Page last updated:
2003 Mar 29 21:51

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
[vox-tech] BIOS Not Installed?
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[vox-tech] BIOS Not Installed?



This is somewhat OT, I suppose, but...

I'm trying to set up a dual-boot system for a friend of mine (Win2K and
RH8.0 -- so it *is* kind of Linux related), but the computer itself is
exhibiting some strange behaviors.

First, when turning the computer on, it displays a message in red
reading, "Abnormal Hardware Configuration -- Press Enter to Continue". 
Once we've pressed Enter, the system does a memory check (several of
them); it detects the hard drive successfully; it then gives a message
reading, "BIOS Not Installed".

Second, the system seems to boot just fine when there is a CD-ROM in the
CD-ROM drive.  It also boots just fine with a floppy disk in the floppy
drive.  But if there is no CD-ROM or floppy, it displays, "Disk Read
Error", and invites us to reboot using <ctrl><alt><del>.  

I tried installing Win2K on the system this afternoon, and was able to
successfully partition my friend's 120GB hard drive[*] and install Win2K
on it.  However, it would not boot into Win2K; it gave me the disk read
error.  Lacking a Win2K boot disk, I tried booting it with a Win98 boot
disk; it gave me the errors I expected ("This ain't no FAT32 file
system, what the hell is this s***?!!?"), which indicates to me that
it's at least reading something from the hard drive when it boots from
the floppy drive.  But booting from the hard drive is impossible.

My theory is that the ide controller on the motherboard is wonky, or
that the motherboard itself is.  I tried, on the suggestion of a mutual
friend, moving around the jumpers on the hard drive but to no avail.

Is there anything I can do in this situation?  I know that one thought
might be to try to install BIOS on the motherboard, but I have no idea
how I'd go about doing that.

Any thoughts would be appreciated.


[*] I know that some older motherboards cannot use a hard drive as large
as 120GB.  I don't think that that's the problem in this case; the
motherboard's documentation states that versions from 1997 or earlier
can handle only up to 80GB, but that versions from 1998 onward can.  The
motherboard in question is from 1998.   It's an old, kludged-together
kind of machine; my friend calls it "Frankenbox".

-- 
Slainte,
Richard S. Crawford
AIM: Buffalo2K / Y!: rscrawford / ICQ: 11640404
http://www.mossroot.com http://www.stonegoose.com
"It is only with our heart that we can see clearly.  What is essential
is
invisible to the eye."  --Antoine de Saint Exupery



Attachment: signature.asc
Description: This is a digitally signed message part



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
O'Reilly and Associates
For numerous book donations.