l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
July 21: Defensive computing: Information security for individuals
Next Installfest:
TBD
Latest News:
Jul. 4: July, August and September: Security, Photography and Programming for Kids
Page last updated:
2003 Mar 12 20:10

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] swapping mice
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] swapping mice



On Wed, Mar 12, 2003 at 05:17:19PM -0800, Robin Snyder wrote:

> It is plugged in and getting some kind of data.  (The receiver box
> lights up.)  I shut down X using ctrl-alt-backspace.  No go.  I even tried
> rebooting, in case ctrl-alt-backspace didn't shut enough processes down.
> (I don't think it does.  Had to reboot to get the Mouseman working again.)
[...]
> What am I missing?  (And can I do this without rebooting?)

  PS/2 style devices are not supposed to be reconnected while the machine
is live.  I don't know the details but I've often seen PS/2 style
devices not operate correctly or at all when they are unplugged and
re-plugged in.  I've read that it's possible to fry the motherboard
controller chip for the PS/2 port by hot-swapping devices.

  While I have never seen a controller chip die by plugging in a PS/2 
device while it's on... I have seen lots of keyboards and mice just not
work after they are disconnected and reconnected.  At least until the
machine is rebooted.
  ... but I've also seem some things reconnect and work okay, just I
avoid doing this because I can't count on it.

  If you want to confirm you have this problem, try unplugging the mouse
a few times and reconnecting it.  See if you can reproduce the "not
working" behavior without changing anything else.

  If you want something that can be unplugged while the machine is on
old style serial and new USB devices both don't mind...


> I have two XF86Config-4's, one for each mouse.  The one for the
> RemotePoint has worked fine in the past.  The one for the Mouseman is the
> one I'm still struggling to configure properly.  When I want to use a
> given mouse, I let XF86Config-4 be a symbolic link to one of these files.
> 
> This seems like the best way to do this, and yet, when I switched
> XF86Config-4 to point to my old, RemotePoint file, my old mouse no longer
> works.  

  Actually there is probably a better way which I've never used before:
man XFree86
#       -pointer pointer-name
#               Use  the  XF86Config(5x)  file InputDevice section
#               called  pointer-name  as  the  core  pointer.   By
#               default  the  core pointer input device referenced
#               by the default Layout section  are  used,  or  the
#               first  relevant InputDevice section when there are
#               no Layout sections.

  You could have both mouse configurations in the config file, and
if you boot up and decide to change mice you could switch to the console 
login and type something like:

  startx -- :1 -pointer Name_Of_Other_Mouse

  This will start a second X server for you and use that mouse driver.
If you can find a way for hot swapping the devices not to cause problems
then when you change mice you can switch to your other copy of X with
something like C-A-F7 (I don't know which windows you have it on,
but that's an idea)...

  At least this way you don't need to keep logging in as root and moving 
symlinks around...
_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Sunset Systems
Who graciously hosts our website & mailing lists!