l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
January 6: Social gathering
Next Installfest:
TBD
Latest News:
Nov. 18: Club officer elections
Page last updated:
2002 Sep 21 20:31

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
[vox-tech] floppy woes
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[vox-tech] floppy woes




Been trying to create a boot disk on my RedHat 7.2 system at work.  Bought
a pack of PC formatted disks (I *should* be able to reformat easily
enough, shouldn't I?).  Set to work trying to create a boot disk.
Couldn't tell what was going on (i.e. going wrong) with qmkbootdisk (the
GUI version) so switched to mkbootdisk.

So far I've tried two disks from the 10-pack.  Both exhibit the same
problems on Linux.  They seem to be both readable and writeable on both
Macintosh and Windows systems, though.  I tried reformatting them on the
Macintosh, first to Mac (which resulted in evidently successful
reformatting, but behaved exactly the same way as the original formatting
on the Linux machine) and then to ProDOS 1.4 MB (which resulted in the
Mac spitting out the disk complaining that the disk could not be erased
because it was defective).

Would appreciate any insight anyone may have into the following errors.

[root@ars164 Thorn]# mount /dev/fd0 /mnt/floppy
mount: block device /dev/fd0 is write-protected, mounting read-only
[root@ars164 Thorn]# mkbootdisk --device /dev/fd0 2.4.7-10
Insert a disk in /dev/fd0. Any information on the disk will be lost.
Press <Enter> to continue or ^C to abort:
mkdosfs: /dev/fd0 contains a mounted file system.
Failed to format /dev/fd0

[root@ars164 Thorn]# umount /dev/fd0
[root@ars164 Thorn]# mkbootdisk --device /dev/fd0 2.4.7-10
Insert a disk in /dev/fd0. Any information on the disk will be lost.
Press <Enter> to continue or ^C to abort:
mkdosfs: unable to open /dev/fd0
Failed to format /dev/fd0


Other stuff I've tried:

(probably mounted disk again before below commands)
[root@ars164 Thorn]# fdformat /dev/fd0
/dev/fd0: Read-only file system
[root@ars164 Thorn]# fdformat /dev/fd0d360
/dev/fd0d360: Device or resource busy
[root@ars164 Thorn]# umount /dev/fd0
[root@ars164 Thorn]# fdformat /dev/fd0d360
/dev/fd0d360: Read-only file system

[root@ars164 Thorn]# mkfs /dev/fd0
mke2fs 1.26 (3-Feb-2002)
/dev/fd0: Read-only file system while setting up superblock

Thanks in advance!
--Alex

"For behold, a 386!  A spectacle of graphics and sound!"
                                    --Strongbad

_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.