l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
April 21: Google Glass
Next Installfest:
TBD
Latest News:
Mar. 18: Google Glass at LUGOD's April meeting
Page last updated:
2002 Aug 31 13:20

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
[vox-tech] robyn snyder's X problem on a laptop
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[vox-tech] robyn snyder's X problem on a laptop



i just realized that the subject of this thread is totally absurd.  i
changed it to something that makes sense.

the references should keep peoples' threading mail clients happy.

---------------

little busy right now, so i'll answer the easy questions.  if nobody
picks up the harder question, i'll try to get to it by monday.

begin Robin Snyder <resnyder@ucdavis.edu> 
> >
> > begin Robin Snyder <resnyder@ucdavis.edu>
> > > I'm in the process of running
> > > dpkg-reconfigure xserver-xfree86 and have gotten to the point of
> > > specifying video modes.
> >
> > try this instead:
> >
> >    # XFree86 -configure
> >
> > i've seen it fail exactly once, and that was because the machine had
> > both a video chipset and a video card at the same time.  it'll certainly
> > work great for a card as well supported as a matrox g400.  matrox fully
> > opened that card for linux developers.
> 
> I tried that already.  It was unable to pick up my mouse

never throw an X configuration away because your mouse doesn't work.
this method usually doesn't pick up the mouse.  but that's small
fry.

> admittedly unusual (a remote, IR pointer).  After killing the screen
> produced by XFree86 -configure, I tried running startx, and it
> wouldn't work.  Again, it seems troubled by not finding the mga_hal
> module.  I'll append the output of XFree86 -xf86config
> /root/XF86Config.new and startx to the end of this message.  (I do see
> that XFree86 has a line "Chipset mgag400 found."  Perhaps I do have an
> mgag chip somewhere?  It wasn't in the specs I received with the machine.)

have you looked your laptop up on:

http://www.linux-laptop.net/


> > > I'm trying to look at my old XF86Config file
> > > (which I backed up before upgrading) to see what I had listed before,
> > > but I can't read the XF86Config file.  I'm told that no such file
> > > exists, even though I can see it listed, with nonzero size, and I have
> > > read permission.  Can anyone tell me what's going on?
> >
> > is . in your $PATH?
> >
> > try using a full pathname: vi /etc/X11/XF86Config
> >
> > use the file command to make sure it's not a broken symlink.
> 
> I tried using the full pathname but was told that the file didn't
> exist.  Similarly, when I tried using file, I got a message saying
> Can't stat <mypath>/XF86Config (No such file or directory).

you put a control character in the filename.  use tab completion.

or do:
script
ls -l /etc/X11/XF*
file /etc/X11/XF*
vi /etc/X11
:w! /tmp/blah
:q!
cat /tmp/blah
exit

then mail the file "typescript" to vox-tech.  unless it's huge.  if it's
huge, send it to me instead.


point of info: when you were at the installfest, we didn't have a net
connection (the first thing we would've done is go to the linux-laptop
website).   we have net access now, so you can bring the laptop to the
next IF.  unfortunately, that's a little far off, i would suggest going
there and looking up your laptop.

they often have canned XF86Config-4's for you to download and use.  they
for my laptop!

hth,
pete
_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.