l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
November 4: Social gathering
Next Installfest:
TBD
Latest News:
Oct. 24: LUGOD election season has begun!
Page last updated:
2002 Aug 12 20:55

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
[vox-tech] natworking
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[vox-tech] natworking



On another note, I am trying to get something to work fruitlessly.
Unfortunately, I am running FreeBSD-4.6 and don't know if anyone could
help.

My workstation is connected to a LAN which is connected to the internet,
it is on a 10. network.

I own a HP 320 LX palmtop computer with Windows CE 1.0.  I have used the
serial cable that it came with and the dial-up networking that it came
with to connect tcp/ip over ppp over serial to my freebsd machine at
57600-8-N-1.  It reports that it connects successfully and a
tcpdump -i ppp0 (the ppp device in FBSD)
shows that in fact, the CE machine does send DNS requests.  The problem is
that the FBSD machine can't handle them.  Here is what I have tried

sysctl net.inet.ip.forwarding = 1 (enabling packet forwarding)
                options IPFIREWALL
                options IPDIVERT    in the kernel
gateway_enable="YES" in /etc/rc.conf to set the sysctl flag upon bootup
and natd -i ep0 to route packets.

This failed.

Then I tried one at a time and used the standard binary 001 010 011 of the
possibilities and failed each time.

Then I tried adding a direct link to the routing table
the Windows CE machine is on a 192.168. network to avoid confusing (I have
tried putting it on a 10. simultaneously with no success)
and so I would do something like:
route add 192.168. 10.0.0.1
or
route add 192.168. 10.0.0.5 (the connected workstation)

also with no success.

The pppd command I have run to connect to the CE device is
pppd  -detach nodefaultroute crtscts lock /dev/cuaa1 57600 : &

I am wondering if anyone would know how I can get the CE's packets routed
to the internet.

I have ran a tcpdump on the network and the ppp at the same time to
actually confirm that no packets make it through.  Could it be possible
that I would have to use the ppp program and have a complex /etc/ppp
script to connect.  This uses the tun device and I don't know if that
would be advantagous.  Furthermore I don't know how to do it using only
ppp.  Since this is Windows CE slattach cu tip and any other unix commands
will fail, it must be ppp or some proprietary desktop connection protocol
that I haven't even looked into yet.

Here is the network info upon connection
ppp0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1500
        inet 192.168.0.101 --> 192.168.0.100 netmask 0xffffff00

Any help would be appreciated.  Thanks.

Sincerely,
	Christopher J. McKenzie

	cjm@ucdavis.edu
	mckenzie@cs.ucdavis.edu
	H: (818) 991-7724
	C: (818) 429-3772
	1815 Mesa Ridge Ave
	Westlake Village, CA 91362

_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
O'Reilly and Associates
For numerous book donations.