l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
November 4: Social gathering
Next Installfest:
TBD
Latest News:
Oct. 10: LUGOD Installfests coming again soon
Page last updated:
2002 Mar 11 11:55

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Setting up X
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Setting up X



Just to add my 2 cents in here--I have a Microsoft Wheel Optical mouse,
and I tried using "Protocol" "PS/2". I had the same effect as Jay did:
when I started X, and moved the mouse, the cursor would jump up to the
upper-right corner of the screen. Replacing "PS/2" with "IMPS/2" worked
like a charm for me.

On Mon, 11 Mar 2002, Peter Jay Salzman wrote:

> begin Jay Strauss <jjstrauss@yahoo.com>
> > I loaded the fonts and I got an X screen.  But my mouse doesn't work (as
> > soon as I touch it, it goes to the upper-right corner of the screen).
>
> does the mouse work correctly under console?  if so...
>
> classic symptom of one of two things:
>
> 1. mouse misconfigured under X (ie- using imps2 when you need to use ps2).
>
>    see   vi `locate README.mouse`  for a list of options that goes under
>    your mouse section.  your mouse section will look something like
> 	this:
>
>    Section "InputDevice"
>       Identifier  "Generic Mouse"
>       Driver      "mouse"
>       Option      "CorePointer"
>       Option      "Protocol"        "ImPS/2"
>       Option      "Resolution"      "2000"
>       Option      "Device"          "/dev/psaux"
>       Option      "Emulate3Buttons" "false"
>       Option      "buttons"         "5"
>       Option      "ZAxisMapping"    "4 5"
>    EndSection
>
>
> 2. gpm and X are both reading from the same device file.
>
>    see vox-tech archives.  we had an extensive thread on this.
>    basically, you want gpm to read the raw mouse device and repeat (raw
>    repeat?) to /dev/gpmdata.  then you want X to read /dev/gpmdata.
>
>
> > Also
> > I deleted the /etc/X11/X86Config file, but I still get the X screen; Where
> > is it getting its config info?
>
> have you tried
>
> updatedb
> locate XF86Config
>
> have you looked to see if there's a /etc/X11/XF86Config-4?
>
> have you looked in /var/log/XFree86.0.log?   the name of the config file
> used is in there.
>
> you're best bet is to take 45 minutes out and read man XF86Config-4.
> read what seems pertinent.   skip what seems totally irrelevent.  gloss
> over stuff that you're not sure if it's relevent or not.
>
> reading this man page in particular is one of the ways to become a less
> frustrated linux user.  it's long and boring, but you'll be thankful you
> did everytime you want to set up or modify X on a system.
>
> by the way, i just noticed this in "gpm -t help":
>
>   autops2    - For PS/2 type mouse, specific protocol will be auto detected
>
> i never saw this before; it must be brand new.  looks kind of cool.
>
> pete
> _______________________________________________
> vox-tech mailing list
> vox-tech@lists.lugod.org
> http://lists.lugod.org/mailman/listinfo/vox-tech
>

-- 
R. Douglas Barbieri
doug@dooglio.net
www.dooglio.net

_______________________________________________
vox-tech mailing list
vox-tech@lists.lugod.org
http://lists.lugod.org/mailman/listinfo/vox-tech



LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Sunset Systems
Who graciously hosts our website & mailing lists!