l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2001 Dec 30 17:14

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
[vox-tech] QuickCam Express success! :)
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[vox-tech] QuickCam Express success! :)

Keywords: QuickCam Express, STV0602, xawtv, digital camera, webcam, getting unsupported hardware working

Well, nobody responded to my scream for help so I ventured out on my own
to figure this thing out.  It only took a few minutes, to my surprise.

What happened last time: I got a free Logitech QuickCam Express
from Verizon for signing up for DSL.  I wanted to get it to work
under Linux so I went through the HOWTOs, the web, etc.  I found
some docs and some sources, but none worked and none helped.  One
thing I found out was that my distribution (Mandrake 8.1) comes
with a Quickcam module (mod_quickcam), but for some reason it
didn't work (it loaded but it gave no valid or invalid message, and no
/dev/videoN appeared).  I also found that mod_quickcam source is available
on sourceforge, not that it helped.

So today, I decided to try some other things.  I tried poking around the
mod_quickcam source.  I noticed the code checks the vendor and product ID
codes so I compared them with the values returned by `usbview`....  It
turned out the product ID wasn't correct (the code had 840, but usbview
reports 870).  I modified the code, with some caution.

Note: If the product ID is different, then the chances are I have a
different model that won't work with the mod_quickcam module... but
hopefully they'll be similar in design and hopefully I'll only need to
tweak mod_quickcam only a little to get it to work.

But the modification didn't do anything, so I put some "printk(...)"
statements to figure out where the code was going and where it wasn't
(printk prints statements in /var/log/messages).  It turned out there was
another place where 840 was hard-coded, so I changed that to 870 as well.

After those two lines of codes were fixed, loading the module showed
/dev/video1 (/dev/video0 is my TV capture card).  I executed `xawtv -c
/dev/video1`, but I didn't see anything.

So the reason is probably that the hardware is slightly different from the
original hardware mod_quickcam was intended for.  I figured I might be
able to get some specs on the chip inside the camera to modify the code,
so I opened up the camera (it's very easy to open) and found the chip to
be STV0602.

The mod_quickcam module was written for STV0600, so that's why simply
modifying the product ID didn't work.

I then did a search on Google.  Hopefully I'll find a completely
different, pre-written module so I won't need to figure thing out for
myself.  Only one website came up.... and it contained modification
information for mod_quickcam to get it to work with the "dexxa webcam
STV0602-AA Agilent QDCS", right on the mod_quickcam website on SourceForge
:P  I applied the changes suggested on the page, and everything worked!:


Note, though, the page does not tell you to change the product ID
information in the source.  I think you need to do that to get it to work
properly.  To do that, apply the changes described on the above link, and
change the occurrences of "870" in the "quickcam.c" files to "840" (there
should be exactly two.)

-Mark (a little wiser today than yesterday)

Mark K. Kim
PGP key available upon request.

vox-tech mailing list

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.