l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2001 Dec 30 17:09

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] Debian Woody XFree86 4.0.3 Woes
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] Debian Woody XFree86 4.0.3 Woes

On Thu, 30 Aug 2001, Jeff Newmiller wrote:

> I installed Debian potato last week. Bit of work, but not too bad. This
> week I decided to upgrade to woody... guess I wanted to live on the edge.  
> Anyway, I am now X-less, because xf86cfg hangs.  It clears the screen,
> briefly shows a diagram of a mouse, and then the clears the screen again,
> paints the generic "gray" background with an X mouse cursor, and hangs. I
> am also having trouble with gpm hanging the console.  In both cases I have
> to login via lan and kill gpm to recover.  I have an ATI Rage IIc (Mach64)
> and I have tried both "microsoft serial/ps2 compatible mouse" and a
> borrowed "intellimouse 1.2a ps2 compatible".  Kernel comes with ps2 driver
> compiled in.  I turned off gpm and pointed /dev/mouse at /dev/psaux to
> experiment with X, but no go.

Sorry to reply to myself, but I seem to have it working now, and thought I
would write about it while I could remember what happened.  I spent quite
a bit of time googling and rebooting to get it working.  Maybe not so much
time next time... (yeah, right...)

a) Any attempt to read from /dev/psaux killed the console (even "cat
/dev/psaux" killed it).  Hmmm... "cat /proc/interrupts" did not show IRQ12
given to PS/2 mouse.  Turns out I had a dead mouse plugged (not mentioned
above) in when the machine booted, so the kernel driver didn't
activate.  Shutdown, plugged in the intellimouse, rebooted, and that mouse
worked... no console lockup. (Now if only I had been able to figure that
out before...)  Don't swap PS2 mice while a system is running, and watch
out for dead mice when booting. :)

b) At this point I am unable to identify a protocol that will work with
this "serial/ps2 compatible" mouse.  I am pretty sure I was using ps2
before, but gpm and X both sent the pointer into scatter mode when I used
it now. Gave up on it, went down to Heron and bought a Logitech Optical
Wheel mouse w/USB to PS2 adapter. Works like a charm.

c) Well, dang, now I have three buttons _and_ a wheel... but I want gpm so
I can copy/paste on text ttys, and gpm refuses to do anything useful if I
repeat the imps2 protocol into /dev/gpmdata so gpm and X can both get at
the pointer. (debian has "gpmconfig" that lets me try these settings out
quickly.)  At least the console doesn't lock up/freeze anymore.

The key was using the "raw" repeat protocol instead of translating to the
MouseSystems protocol like Mike Simons recommended.  Then I could let X do
the "zaxismapping" thing itself. So, the configuration summary is:



Section "InputDevice"
    Identifier            "Mouse1"
    Driver                "mouse"
    Option "Protocol"     "imps/2"
    Option "Device"       "/dev/gpmdata"
    Option "Buttons"      "5"
    Option "ZAxisMapping" "4 5"

And the wheel scrolls up and down in Konqueror, and I can copy/paste
between X and console.

My lessons today: Keep PS2 mice plugged in, and set gpm to repeat raw.  
Oh, and xf86config has not been obsoleted in v4 like so many other v3.3
XFree86 bits and pieces have.  xf86cfg wouldn't work for me, even with the
working intellimouse.

Jeff Newmiller                        The     .....       .....  Go Live...
DCN:<jdnewmil@dcn.davis.ca.us>        Basics: ##.#.       ##.#.  Live Go...
                                      Live:   OO#.. Dead: OO#..  Playing
Research Engineer (Solar/Batteries            O.O#.       #.O#.  with
/Software/Embedded Controllers)               .OO#.       .OO#.  rocks...2k

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.