l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
January 6: Social gathering
Next Installfest:
TBD
Latest News:
Nov. 18: Club officer elections
Page last updated:
2001 Dec 30 17:08

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] eth0 troubles
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] eth0 troubles



I JUST finished this configuration on my RH 7.1/eth0/hub/Cable Modem.

The issue that was frustrating was the 'ifconfig','static-routes',
gateway, netmask and /broadcast on eth0/ with netmask 255.255.255.0
//and// setting the /default gateway/.

    machine: dev-server-1.msdincdev.com
    ip:            65.3.93.207
    2nd ip on other machine:  65.3.93.137
    gateway: 65.3.93.1


NOTE:  you should have static routes in /etc/sysconfig/static-routes
to your DNS servers as well as their entries in /etc/resolv.conf

Also, enter a network (mask 255.255.255.0) for your dns server's IP.


[ifconfig -a output]
---------------------------
eth0      Link encap:Ethernet  HWaddr 00:E0:B8:11:78:21
          inet addr:65.3.93.207  Bcast:65.3.93.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1765537 errors:0 dropped:0 overruns:0 frame:0
          TX packets:126807 errors:0 dropped:0 overruns:0 carrier:0
          collisions:150 txqueuelen:100
          Interrupt:9 Base address:0x1080

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:3924  Metric:1
          RX packets:1193 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1193 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
----------------------------


route output:
---------------------------
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
dev-server-1.ms dev-server-1.ms 255.255.255.255 UGH   1      0        0 eth0
c1245308-a      dev-server-1.ms 255.255.255.255 UGH   1      0        0 eth0
hydrogen.liquid 65.3.93.1       255.255.255.255 UGH   5      0        0 eth0
65.3.93.1       65.3.93.1       255.255.255.255 UGH   1      0        0 eth0
proxy2.denver1. 65.3.93.1       255.255.255.255 UGH   1      0        0 eth0
msdesigninc.com 65.3.93.1       255.255.255.255 UGH   5      0        0 eth0
localhost       localhost       255.255.255.255 UGH   1      0        0 lo
proxy1.denver1. 65.3.93.1       255.255.255.255 UGH   1      0        0 eth0
65.3.93.0       *               255.255.255.0   U     0      0        0 eth0
65.3.93.0       65.3.93.1       255.255.255.0   UG    5      0        0 eth0
24.10.132.0     65.3.93.1       255.255.255.0   UG    5      0        0 eth0
127.0.0.0       localhost       255.0.0.0       UG    5      0        0 lo
127.0.0.0       *               255.0.0.0       U     15     0        0 lo
default         65.3.93.1       0.0.0.0         UG    30     0        0 eth0
---------------------------


route -n output:
---------------------------
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
65.3.93.207     65.3.93.207     255.255.255.255 UGH   1      0        0 eth0
65.3.93.137     65.3.93.207     255.255.255.255 UGH   1      0        0 eth0
66.78.41.2      65.3.93.1       255.255.255.255 UGH   5      0        0 eth0
65.3.93.1       65.3.93.1       255.255.255.255 UGH   1      0        0 eth0
24.10.132.180   65.3.93.1       255.255.255.255 UGH   1      0        0 eth0
66.78.41.53     65.3.93.1       255.255.255.255 UGH   5      0        0 eth0
127.0.0.1       127.0.0.1       255.255.255.255 UGH   1      0        0 lo
24.10.132.178   65.3.93.1       255.255.255.255 UGH   1      0        0 eth0
65.3.93.0       0.0.0.0         255.255.255.0   U     0      0        0 eth0
65.3.93.0       65.3.93.1       255.255.255.0   UG    5      0        0 eth0
24.10.132.0     65.3.93.1       255.255.255.0   UG    5      0        0 eth0
127.0.0.0       127.0.0.1       255.0.0.0       UG    5      0        0 lo
127.0.0.0       0.0.0.0         255.0.0.0       U     15     0        0 lo
0.0.0.0         65.3.93.1       0.0.0.0         UG    30     0        0 eth0

---------------------------

Notice the /default/ routes are 0's, which
basically allows the local ISP network
to route your non-static and non-local
traffic when you don't have a specified
route.



Nick wrote:

> Here is the situation:
> I moved to a place where we have ADSL.  My system was configured to use my
> ethernet card but with no proto and the IP of 168.192.0.1  When I moved I
> switched that to use dhcp and wiped the IP address from netcfg.  Everything
> worked like a champ.  Then I got dumb.
>
> I found a eth0.OLD in the netcfg interfaces dialoge.  So I deleted it.  "Why
> should it need it?" was my thought.  Well that killed the eth0's connection.
> I restarted it and it worked fine again.  Well that was Monday night.  When I
> went to check email on Tuesday morning eth0 would not work.  I ran down the
> diagnostic this way:
> 1)  check to see if eth0 had obtained an IP from the router; it had.
> 2) check to make sure eth0 was sending by watching the pretty little lights
> on the card; they did
> 3) check to make sure the hub is registering the activity to it; it was
> 4) check to see if the router was recieving from the hub; it was.  However
> there was no activity lights working on the WAN side of the display on the
> router or on the DSL modem itself.
>
> This all seemed really wierd to me.  So figured that the hardware was
> funtioning but maybe configuration was somehow messed up with the eth0.  I
> decided the best thing to do was to reinstall RH 7.1.  It was not big thing
> because I didn't have anything but a few text docs to backup to disk.  I did
> reintstall RH7.1 and the problem didn't go away.  I am at a total lose as to
> what to do to fix the problem.  I have a Linksys Etherfast 10/100 card and it
> has worked fine in the past and seems to be now.
>
> If anyone could lend a hand I would greatly appreciate it.  I don't want to
> go back to having to use Windows (SoS - Software of Shame).  I am using dial
> up through the college right now so I will check email once or twice a day or
> if anyone is ambitious and would not mind giving me a ring at 530-297-1750 I
> would be indebted.
>
> Nick


LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
O'Reilly and Associates
For numerous book donations.