l i n u x - u s e r s - g r o u p - o f - d a v i s
Next Meeting:
July 7: Social gathering
Next Installfest:
Latest News:
Jun. 14: June LUGOD meeting cancelled
Page last updated:
2001 Dec 30 17:04

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] AAARRRGGGHHHH! (Translation: Linux got hosed)
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] AAARRRGGGHHHH! (Translation: Linux got hosed)

On Wed, 9 May 2001, Peter Jay Salzman wrote:

> whoa.  wait a minute.  don't reinstall linux just yet.
> what happened?
> what makes you think the root partition is hosed?

There is a certain action that, occasionally, reboots the system
unexpectedly.  My guess is that the action (`/sbin/ifdown eth0` followed
by `/sbin/ifup eth0` as a user, which is supposed to work as a user if I
check a box in netcfg) somehow interacts with my Voodoo 3 3500TV kernel
module (allows me to watch television); or, perhaps netcfg isn't working

Anyway, it rebooted again today, which was fine -- fsck should run some
checks then everything will be back to normal, right?  Wrong... this time,
fsck somehow disabled certain sectors of the hard drive, causing it to
be inaccessible.  At least "/var/log/messages" showed that kernel tried to
access non-existing sectors.  But more importantly, I realized something's
wrong when I couldn't log into X -- gdm comes up fine, but when I try to
log in, I get a message saying "/etc/X11/xdm/GiveConsole" returned a
nonzero value, then it kicks me back out to the login screen.

So I rebooted, hoping the second boot re-recognize the partition modified
by fsck.  Didn't work.  Didn't boot at all, actually -- kernel panic.

So I tried to access the partition via Explore2fs under Windows (a program
that lets you access Linux partitions from Windows.)  It won't let me
access that partition at all -- error.  Other partitions are perfectly

I think the partition is hosed.  I don't mind reinstalling the root
partition -- just root files (plus some configuration in /etc, but... oh

> depends.  the rpm database, i believe, goes under /var.  perhaps
> /var/lib/rpm.

Darn.  /var is hosed, too (on the same partition.)

> nothing.  if you *install* linux, rpm shouldn't check any database which may
> exist.  installing linux and populating an rpm database is MUCH different
> than doing rpm -U a billion times.

so overwrite the existing files?

> ps- you never heard people talk about it, but i always back up /etc.

Exactly what I thought I should do as soon as I realized the root got


Mark K. Kim
PGP key available upon request.

LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
O'Reilly and Associates
For numerous book donations.