l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
August 5: Social gathering
Next Installfest:
TBD
Latest News:
Jul. 4: July, August and September: Security, Photography and Programming for Kids
Page last updated:
2001 Dec 30 17:04

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
[vox-tech] Dual-booting Linux and Windows 2000
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[vox-tech] Dual-booting Linux and Windows 2000



Hi all,

I have a 9GB drive with Windows 2000 installed on it. I wanted to make a
dual-boot system, so I added another 2.5GB IDE drive I had lying around
(jumpered to slave). Then I setup an FTP installation of RedHat's Wolverine
and let it run during the weekend.

On return, I had a Red Hat Linux bootable installation on hdb. I also made a
boot disk. fdisk shows:

Cylinders    Device        Type
1-5            /dev/hdb1    boot
6-621        /dev/hdb2    extended partition
6-604        /dev/hdb5    /
605-621    /dev/hdb6    swap

Where cylinders are 8164*512K = 4MB each.

To make a bootfile for NTLoader to load linux, I did:

dd if=/dev/hdb1 of=/bootsect.lnx bs=512 count=1

then I copied this file to diskette.

To get Windows 2000 back (and in accordance with the Linux-NT HOWTO on
www.linuxdoc.org), I booted a DOS disk and ran fdisk /mbr, then repaired my
NT bootsector using the repair procedure. (Actually, I've done this twice
... the second time, I just fdisk'ed). After I could boot to W2K, I copied
bootsect.lnx onto C: and added the following line to boot.ini

C:\BOOTSECT.LNX="Red Hat Linux (Wolverine)"

Now, when I tried to use NT Loader to get to Linux, I get the error:

BOOT Failed

However, I can boot W2K. I can also boot to Linux using the boot disk. So, I
tried copying the floppy's boot sector using

dd if=/dev/fd0 of=/bootsec.lnx bs=512 count=1

but this generates the same results.

I don't want to run LILO, since that will overwrite my NT Bootloader. I
tried that already, that adds the line:

boot=/dev/hda

to /etc/lilo.conf and erases the NT Bootloader, until I fdisk it.

Any hints on completing this? I can dual boot by inserting the floppy, but
I'd like to manage the process in NT Loader.

Thanks,

--Adam


LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Appahost Applications
For a significant contribution towards our projector, and a generous donation to allow us to continue meeting at the Davis Library.