l i n u x - u s e r s - g r o u p - o f - d a v i s
L U G O D
 
Next Meeting:
November 4: Social gathering
Next Installfest:
TBD
Latest News:
Oct. 10: LUGOD Installfests coming again soon
Page last updated:
2001 Dec 30 17:00

The following is an archive of a post made to our 'vox-tech mailing list' by one of its subscribers.

Report this post as spam:

(Enter your email address)
Re: [vox-tech] RHL 7 and kernel 2.4.0 woes
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vox-tech] RHL 7 and kernel 2.4.0 woes



hi jan,

jeff took the words right out of my mouth.   :)

but let me add to it.  "root=" is indeed a _VALID_ parameter to pass to the
kernel, but it doesn't do what you think it should.

when you pass "root=" to the kernel, it tells the kernel HOW to mount the
root filesystem.  the valid entries are "ro", "rw" or "debug".   as you can
imagine, ro means to mount / as read only.   rw means to mount / as read
write, and debug effects the "level of importance" for which messages are
printed to the console during kernel initialization.

what you want to do is tell the kernel where to FIND the filesystem, not how
to mount it.   to do that, you use the "root=" parameter as a lilo
directive, not as a kernel argument (which is what append= does).

some lilo commands get written directly into the kernel itself.  that's why
you can willy-nilly compile a kernel and have it work on all machines.  the
location of / is hardwired into the kernel image.  looking at the issue this
way, it should make more sense that you want to issue a lilo directive, not
an argument to be passed to the kernel at boot time.

pete

On Thu 15 Feb 01, 11:11 AM, jdnewmil@dcn.davis.ca.us said: 
> On Thu, 15 Feb 2001, Jan Wynholds wrote:
> 
> [...]
> 
> > Here's my scoop:
> > 
> > Last night I was trying to compile with old modutils
> > (not 2.4.0 as recommended), old e2fsprogs (not 1.19 as
> > recommended), and old ppp (not 2.4.0 as recommended). 
> > So I upgraded all those, and tried again.  
> > 
> > And got a bit farther.  Makes and such were done to
> > completion and without terrible errors.  So, I
> > modified lilo.conf, ran lilo (in the make install
> > script), and crossed my fingers.  Anyhow, when I tried
> > to boot, the messages went somewhat like:
> > 
> > Uncompressing linux.......
> > Ok booting the kernel
> > TCP Stuff....
> > IPv4 blah blah
> > [more lines of stuff]
> > kernel panic: VFS: unable to mount root file system:
> > /dev/hda2 bad parameter
> > 
> > Or some such.  It's roughly 3:30 am, and I don't
> > remember the exact messages, but it hangs there.  I
> > have to reboot and use the old kernel :(.  It's weird,
> > cause it begins to load some stuff, but when it tries
> > to find the root file system, it hangs.  In the docs
> > it says to use a line in lilo.conf to pass the boot
> > partition to the kernel so I added the line:
> > 
> > image=vmlinux-2.4.1
> >     label=linux241
> >     append = "root=/dev/hda2"
> 
> mmm... I think the "root=" is lilo information, not kernel information.
> Put it in just like the label line... no append.
> 
> ---------------------------------------------------------------------------
> Jeff Newmiller                        The     .....       .....  Go Live...
> DCN:<jdnewmil@dcn.davis.ca.us>        Basics: ##.#.       ##.#.  Live Go...
> Work:<JeffN@endecon.com>              Live:   OO#.. Dead: OO#..  Playing
> Research Engineer (Solar/Batteries            O.O#.       #.O#.  with
> /Software/Embedded Controllers)               .OO#.       .OO#.  rocks...2k
> ---------------------------------------------------------------------------
> 

-- 
"It's better to be safe than assimilated."                   p@dirac.org
                      -- Chakotay                            www.dirac.org/p


LinkedIn
LUGOD Group on LinkedIn
Sign up for LUGOD event announcements
Your email address:
facebook
LUGOD Group on Facebook
'Like' LUGOD on Facebook:

Hosting provided by:
Sunset Systems
Sunset Systems offers preconfigured Linux systems, remote system administration and custom software development.

LUGOD: Linux Users' Group of Davis
PO Box 2082, Davis, CA 95617
Contact Us

LUGOD is a 501(c)7 non-profit organization
based in Davis, California
and serving the Sacramento area.
"Linux" is a trademark of Linus Torvalds.

Sponsored in part by:
Sunset Systems
Who graciously hosts our website & mailing lists!